<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://cwdetroit.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="keywords" content="news, syndicated local, ticker, family attack, flossie bray, harper woods, jonathan welch, robert bray, zlayiah frazier" />
<meta property="fb:pages" content="245397755489628" />
<title>Mom Stabbed By Son, Jonathan Welch, Becomes 3rd Person To Die In Family Attack &#8211; CW50 Detroit</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.mp.lura.live' />
<link rel='dns-prefetch' href='//cdn.parsely.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="CW50 Detroit &raquo; Feed" href="https://cwdetroit.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://cwdetroit.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsKBQxAJxlnxMierYUT7i+oSUDSuoxMr22G80hkdUVrggFyh3DJjBmqxIrCbwbKm6l5Qz3EQKpm1rN/AThMGgW9iYkES773CkOnnOEMRVahv9Nmh1PdwPVNCsJ0zd5kNRLeRcJK54afGowbD2pMjz/P9USG3i0v+9hstuPI7DcD7tD091rZ9f' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://cwdetroit.cbslocal.com/_static/??-eJytU9tOwzAM/SGyrNIG5QHxLWliddmcixJ3Vf8et3SUUmAt4i2+nGMfO5ZtFDp4Ak+STuAgS11lgUErlJk6hJ3O+UH+lma9xsb0rpxlVDUIAhdR0QpsDwFkp6d8PztiU1ufpQumQY4MCcIpz0XTwEVdhMPGlltrppZXdPFFb/pL5/kUEulwY5nMDeXBVWDe8cNToM0ktCKFod4og1VYjSCu0/BmccPUsmLghatUSaVu/B3O+iXizELBWDVudmbwlDtIAqFWulsH59hnewZaPXHecg30sfH+vSBxjbjBzkBRsdpiv3tecFCIIobMr5Uncv/jOpUuPfV4FgFD+peDmPOGK6Q22W8u8yfpPcfo6DGv7qV4PD7tD2VZlG9WZ5cA' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type="text/javascript" src="https://cwdetroit.cbslocal.com/_static/??-eJy1UEEOwjAM+xBdxIAhDoi3lC4bLWlalha031MmDuw2kDhZcWzHCjyiMoETcoJ0QY8C5iyKgtEElg3ltlBOIAYaO0tUecuVkxUsNbpFjki5tyzgQ5upbHQ7mQuoe/2ZMIu+ZRzGNywSKW/7QSf8qdMkUF6z7nF4Rc8IVe5dU4hfPafLbJINLP8ohFQmTlJyT/64bnbNZnPY11v3BLEGukA=" ></script><script src='https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js?ver=5.8.4' id='partner__video__anvato-js'></script>
<script type="text/javascript" src="https://cwdetroit.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILYKNIQ6Ib+nSqEuVphNp2e9TTVy4sJtlP9uwrR1mLaQFykKJDHC2TjI6AVaU6psVDZxfyPhNfWLto53gX7HxQfLs5JD8uXgVRqHDzio1sBqk7Ku0ZGMfqOwTX9kmnulxnq7TMNxvlzF+AAroVNg=" ></script><link rel="https://api.w.org/" href="https://cwdetroit.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://cwdetroit.cbslocal.com/wp-json/wp/v2/posts/94708" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cwdetroit.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cwdetroit.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.4" />
<link rel='shortlink' href='https://cbsloc.al/3cy836k' />
<link rel="alternate" type="application/json+oembed" href="https://cwdetroit.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcwdetroit.cbslocal.com%2F2022%2F07%2F20%2Fmom-stabbed-by-son-jonathan-welch-becomes-3rd-person-to-die-in-family-attack%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://cwdetroit.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcwdetroit.cbslocal.com%2F2022%2F07%2F20%2Fmom-stabbed-by-son-jonathan-welch-becomes-3rd-person-to-die-in-family-attack%2F&#038;format=xml" />
<meta name="parsely-title" content="Mom Stabbed By Son, Jonathan Welch, Becomes 3rd Person To Die In Family Attack" />
<meta name="parsely-link" content="http://cwdetroit.cbslocal.com/2022/07/20/mom-stabbed-by-son-jonathan-welch-becomes-3rd-person-to-die-in-family-attack/" />
<meta name="parsely-type" content="post" />
<meta name="parsely-image-url" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/Untitled-design-41-1.png?w=150&amp;h=150&amp;crop=1" />
<meta name="parsely-pub-date" content="2022-07-20T13:40:33Z" />
<meta name="parsely-section" content="News" />
<meta name="parsely-tags" content="family attack,flossie bray,harper woods,jonathan welch,robert bray,zlayiah frazier" />
<meta name="parsely-author" content="cbslocaladmin" />
<style type='text/css'>img#wpstats{display:none}</style>
	
<meta property="og:title" content="Mom Stabbed By Son, Jonathan Welch, Becomes 3rd Person To Die In Family Attack" /><meta property="og:image" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/Untitled-design-41-1.png?w=1500" /><meta property="og:image:secure_url" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/Untitled-design-41-1.png?w=1500" /><meta property="og:image:width" content="1500" /><meta property="og:image:height" content="845" /><meta property="og:description" content="A third person has died, days after a Detroit-area man released on bond in a domestic violence case was accused of attacking his girlfriend and family, authorities said." /><meta property="og:type" content="article" /><meta property="og:url" content="https://cwdetroit.cbslocal.com/2022/07/20/mom-stabbed-by-son-jonathan-welch-becomes-3rd-person-to-die-in-family-attack/" /><meta property="article:published_time" content="2022-07-20T09:40:33+00:00" /><meta property="article:suggested-social-copy" content="A third person has died, days after a Detroit-area man released on bond in a domestic violence case was accused of attacking his girlfriend and family, authorities said." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="News,Syndicated Local,Ticker" /><meta property="article:publisher" content="http://www.facebook.com/cw50detroit" /><meta property="article:author" content="http://www.facebook.com/cw50detroit" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/Untitled-design-41-1.png?w=1500"><meta name="twitter:title" content="Mom Stabbed By Son, Jonathan Welch, Becomes 3rd Person To Die In Family Attack"/><meta name="twitter:description" content="A third person has died, days after a Detroit-area man released on bond in a domestic violence case was accused of attacking his girlfriend and family, authorities said."/><meta name="twitter:site" content="/cw50detroit"/>
<link rel="canonical" href="https://cwdetroit.cbslocal.com/2022/07/20/mom-stabbed-by-son-jonathan-welch-becomes-3rd-person-to-die-in-family-attack/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://cwdetroit.cbslocal.com/2022/07/20/mom-stabbed-by-son-jonathan-welch-becomes-3rd-person-to-die-in-family-attack/?amp">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/cwdetroit.cbslocal.com","url":"https:\/\/cwdetroit.cbslocal.com","name":"CW50 Detroit","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/cwdetroit.cbslocal.com\/wp-content\/uploads\/sites\/31326028\/2018\/07\/4_detroit_cw50.png?w=158"}},"url":"https:\/\/cwdetroit.cbslocal.com\/2022\/07\/20\/mom-stabbed-by-son-jonathan-welch-becomes-3rd-person-to-die-in-family-attack\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/cwdetroit.cbslocal.com\/2022\/07\/20\/mom-stabbed-by-son-jonathan-welch-becomes-3rd-person-to-die-in-family-attack\/"},"headline":"Mom Stabbed By Son, Jonathan Welch, Becomes 3rd Person To Die In Family Attack","description":"A third person has died, days after a Detroit-area man released on bond in a domestic violence case was accused of attacking his girlfriend and family, authorities said.","image":"https:\/\/cwdetroit.cbslocal.com\/wp-content\/uploads\/sites\/31326028\/2022\/07\/Untitled-design-41-1.png?w=1500","keywords":["News","Syndicated Local","Ticker","family attack","Flossie Bray","Harper Woods","Jonathan Welch","Robert Bray","Zlayiah Frazier","news","Mom Stabbed By Son, Jonathan Welch, Becomes 3rd Person To Die In Family Attack"],"datePublished":"2022-07-20T09:40:33+00:00","dateModified":"2022-07-20T09:40:33+00:00","author":{"@type":"Organization","name":"CW50 Detroit"},"video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"City Begins $6M Remake Of Roosevelt Park In Detroit's Corktown","description":"The city of Detroit broke ground on a $6 million transformation of Roosevelt Park, located in front of Michigan Central Station.","thumbnailUrl":"https:\/\/m101675-ucdn.mp.lura.live\/anv-iupl\/D41\/E28\/D41E28F658720F8A1C147115E7E75A69.jpg?Expires=2082758400&KeyName=mcpkey1&Signature=oKvXyLjVERfsfkh6G9-BgfH_Brk","uploadDate":"2022-07-20","duration":"T47S","contentUrl":"https:\/\/cwdetroit.cbslocal.com\/video\/6267520-city-begins-6m-remake-of-roosevelt-park-in-detroits-corktown\/","embedUrl":"https:\/\/cwdetroit.cbslocal.com\/video\/6267520-city-begins-6m-remake-of-roosevelt-park-in-detroits-corktown\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script>
<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CW.DET","news",["momstabbedbysonjonathanwelchbecomes3rdpersontodieinfamilyattack","post","article","news","syndicatedlocal","ticker","familyattack","flossiebray","harperwoods","jonathanwelch","robertbray","zlayiahfrazier","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("2");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-64" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-64" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"news;syndicated-local;ticker;","dimension2":"article"});gtag("config","UA-2438645-64");</script>

<!-- WP Header - End -->

	<meta name="description" content="A third person has died, days after a Detroit-area man released on bond in a domestic violence case was accused of attacking his girlfriend and family, authorities said." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-94708 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://cwdetroit.cbslocal.com" id="header-logo"><img src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2018/07/4_detroit_cw50.png?w=158" alt="CW50 Detroit" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Latest Update</strong></div></div><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list enable-type-icons column-count-3 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">News</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/2022/07/19/detroit-recreational-pot-shop-applications-set-to-open-in-august/" title="Detroit Recreational Pot Shop Applications Set To Open In August" class="cbs-thumbnail-link item-1658266759" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/CW50-DETROIT-RECREATIONAL-POT.00_00_00_00.Still001.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Recreational Pot Shop Applications Set To Open In August</strong><em class="description">The city has medical marijuana centers but not recreational ones, unlike nearby cities.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/07/19/michigan-reports-16445-new-covid-19-cases-149-deaths-over-the-last-week/" title="Michigan Reports 16,445 New COVID-19 Cases, 149 Deaths Over The Last Week" class="cbs-thumbnail-link item-1658257512" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/shutterstock_1624635628-3.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Michigan Reports 16,445 New COVID-19 Cases, 149 Deaths Over The Last Week</strong><em class="description">The Michigan Department of Health and Human Services announced new coronavirus cases and additional deaths in the state. Here&#039;s everything to know.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/07/18/new-988-suicide-hotline-prevent-number-aims-to-make-it-easier-to-get-help/" title="New 988 Suicide Hotline Prevent Number Aims To Make It Easier To Get Help" class="cbs-thumbnail-link item-1658178363" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/CW50-NAMI-988.00_01_15_07.Still001.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">New 988 Suicide Hotline Prevent Number Aims To Make It Easier To Get Help</strong><em class="description">People in crisis can call or text &quot;9-8-8&quot; to reach a mental health specialist.</em></div></a></div>
</div></div><div id="embed-list-2" class="embed-item embed-list enable-type-icons column-count-1 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Eye on Detroit</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/2021/09/01/dutton-farm/" title="The Mission of Dutton Farm" class="cbs-thumbnail-link item-1630549843 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/02/dutton.jpg?w=625&#038;h=352&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">The Mission of Dutton Farm</strong><em class="description">Changing The Future of Possibilities For People With Disabilities</em></div></a></div>
</div></div><div id="embed-list-3" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Coming Up</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/2022/07/18/werewolves-of-kentucky-mysteries-decoded/" title="Werewolves of Kentucky - Mysteries Decoded" class="cbs-thumbnail-link item-1658117471" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/ROS_MD-7.20.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Werewolves of Kentucky - Mysteries Decoded</strong><em class="description">U.S. Navy veteran turned private investigator Jennifer Marshall and paranormal researcher Heidi Hollis investigate a series of mysterious encounters with an unknown creature in the Bluegrass hills of Kentucky.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/07/18/fatberg-wellington-paranormal/" title="Fatberg - Wellington Paranormal" class="cbs-thumbnail-link item-1658117437" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/WPN-7.20.jpg?w=627&#038;h=352&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Fatberg - Wellington Paranormal</strong><em class="description">When a large, congealed blob of fat in the Wellington sewers becomes sentient, Officers Minogue and O&#039;Leary go underground to confront the monster.</em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://cwdetroit.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-4" class="embed-item embed-list enable-type-icons column-count-6 block-type-grid" ><div class="wrapper">
<div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/2022/07/20/police-seek-suspect-who-allegedly-hit-victim-with-his-car-in-detroit/" title="Police Seek Suspect Who Allegedly Hit Victim With His Car In Detroit" class="cbs-thumbnail-link item-1658327034" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Police Seek Suspect Who Allegedly Hit Victim With His Car In Detroit</strong><em class="description">The Detroit Police Department is searching for a suspect who is accused of striking a victim with his vehicle in a CVS parking lot.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/07/20/judge-strikes-2018-michigan-gop-effort-to-attack-minimum-wage-hike/" title="Judge Strikes 2018 Michigan GOP Effort To Attack Minimum Wage Hike" class="cbs-thumbnail-link item-1658325050" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/gavel02-5.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Judge Strikes 2018 Michigan GOP Effort To Attack Minimum Wage Hike</strong><em class="description">An effort by Republicans in the Michigan Legislature to weaken minimum wage and sick leave laws was declared unconstitutional Tuesday.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/07/20/mom-stabbed-by-son-jonathan-welch-becomes-3rd-person-to-die-in-family-attack/" title="Mom Stabbed By Son, Jonathan Welch, Becomes 3rd Person To Die In Family Attack" class="cbs-thumbnail-link item-1658324433" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/Untitled-design-41-1.png?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Mom Stabbed By Son, Jonathan Welch, Becomes 3rd Person To Die In Family Attack</strong><em class="description">A third person has died, days after a Detroit-area man released on bond in a domestic violence case was accused of attacking his girlfriend and family, authorities said.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/07/20/12-year-old-shot-killed-by-13-year-old-in-detroit-home/" title="12-Year-Old Shot, Killed By 13-Year-Old In Detroit Home" class="cbs-thumbnail-link item-1658323353" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/shutterstock_1191163906-7.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">12-Year-Old Shot, Killed By 13-Year-Old In Detroit Home</strong><em class="description">A 12-year-old boy has been shot and killed by a 13-year-old boy in a home on Detroit&#039;s west side, police said.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/07/19/oakland-county-sheriffs-office-welcomes-2-new-puppies-to-its-k9-comfort-unit/" title="Oakland County Sheriff&#039;s Office Welcomes 2 New Puppies To Its K9 Comfort Unit" class="cbs-thumbnail-link item-1658287358" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/FX-jzRaVUAE4B3x.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Oakland County Sheriff&#039;s Office Welcomes 2 New Puppies To Its K9 Comfort Unit</strong><em class="description">The department announced two new members -- Sadie and Wildcat -- to its K9 Comfort Unit. Officials say the newest members join a collection of King Charles Cavalier Spaniel purebred dogs.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/07/19/ford-reveals-new-2023-f-150-raptor-r/" title="Ford Reveals New 2023 F-150 Raptor R" class="cbs-thumbnail-link item-1658286669" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/FordF150RaptorR.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Ford Reveals New 2023 F-150 Raptor R</strong><em class="description">The truck, which is starting at $109,000, has a 5.2-liter V-8 engine that produces 700 horsepower.</em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-2 w-link"><a href="http://cwdetroit.cbslocal.com/cw-detroit-tv-schedule" title="TV Schedule" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">TV Schedule</strong></div></a></li><li class="menu-top-item item-3 w-link"><a href="http://cwdetroit.cbslocal.com/tag/cw50-street-team/" title="Street Team" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Street Team</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://cwdetroit.cbslocal.com/category/detroit-proud/" title="Detroit Proud" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Detroit Proud</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-5" class="embed-item embed-list enable-type-icons column-count-6 block-type-grid" ><div class="wrapper">
<div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/2020/02/24/detroit-proud-playlist-hamtramck-music-festival/" title="Detroit Proud Playlist: Hamtramck Music Festival" class="cbs-thumbnail-link item-1582565278" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Hamtramck Music Festival</strong><em class="description">The City of Hamtramck comes alive with art, culture, and music via the Hamtramck Music Festival, featuring 200 bands playing 24 venues and restaurants.</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/09/04/detroit-proud-playlist-dally-in-the-alley/" title="Detroit Proud Playlist: Dally In The Alley" class="cbs-thumbnail-link item-1567614651" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Dally In The Alley</strong><em class="description">Dally in the Alley is the go-to event of the summer to discover your new favorite local headliner or underground group. Get into the spirit with this week&#039;s Playlist!</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/07/16/detroit-proud-playlist-pig-whiskey-2019/" title="Detroit Proud Playlist: Pig &amp; Whiskey 2019" class="cbs-thumbnail-link item-1563305958" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Pig &amp; Whiskey 2019</strong><em class="description">Pig &amp; Whiskey Festival encapsulates a Michigan summer in one weekend. We’ve curated a schedule with an eclectic mix of bands that pairs well with any kind of BBQ, brew, or whiskey that you choose to enjoy alongside the music.</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/03/04/detroit-proud-playlist-hamtramck-music-festival-2019/" title="Detroit Proud Playlist: Hamtramck Music Festival 2019!" class="cbs-thumbnail-link item-1551716768" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Hamtramck Music Festival 2019!</strong><em class="description">It&#039;s that time of year again! We’ve selected an eclectic mix of can’t-miss bands playing this weekend&#039;s Hamtramck Music Festival for this week&#039;s Detroit Proud Playlist!</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/02/18/detroit-proud-playlist-guest-dj-vazum-frontman-zach-pliska/" title="Detroit Proud Playlist: Guest DJ - VAZUM Frontman Zach Pliska!" class="cbs-thumbnail-link item-1550466084" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2013/08/dpplaylistimage2.jpg?w=478&#038;h=359&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Guest DJ - VAZUM Frontman Zach Pliska!</strong><em class="description">This week, we have a special Guest DJ-ed playlist, curated by VAZUM frontman Zach Pliska! Zach put his own spin on our Detroit Proud Playlist this week - check out his picks below!</em></div></a><a href="https://cwdetroit.cbslocal.com/2018/12/03/detroit-proud-playlist-week-of-12-3/" title="Detroit Proud Playlist: Week of 12/3" class="cbs-thumbnail-link item-1543848574" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2013/07/dpplaylistimage2.jpg?w=478&#038;h=359&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Week of 12/3</strong><em class="description">The playlist is here for another week of Detroit music! We have new tunes, old tunes, and a little something for everyone. Check it out!</em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-5 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></div><div class="submenu"><div class="wrapper"><div id="embed-list-6" class="embed-item embed-list enable-type-icons column-count-3 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="http://cwdetroit.cbslocal.com/video/category/spoken-word-wkbdtv/">News</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/video/6267332-science-of-weather-harmful-algal-blooms/" title="Science of Weather: Harmful Algal Blooms" class="cbs-thumbnail-link item-1658265780 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://h101675-ecdn.mp.lura.live/1/998160/anv-pvw/B2D/B22/B2DB22AECF1FBD2522337472BDDA47E1_2.jpg?aktaexp=2082787200&#038;aktasgn=dffd205c838ae1c0a579760f00a2f54a"></span></div><div class="title-wrapper"><strong class="title">Science of Weather: Harmful Algal Blooms</strong><em class="description">Science of Weather: Harmful Algal Blooms</em></div><time datetime="2022-07-19T21:23:00+00:00" title="July 19, 2022 at 5:23 pm">17 hours ago</time></a><a href="https://cwdetroit.cbslocal.com/video/6267267-automakers-targeting-average-households-with-new-crop-of-evs/" title="Automakers Targeting Average Households With New Crop Of EVs" class="cbs-thumbnail-link item-1658253180 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://h101675-ecdn.mp.lura.live/1/998160/anv-pvw/DE9/8D4/DE98D4FC0213D5A2409563C091FF29D4_6.jpg?aktaexp=2082787200&#038;aktasgn=1d9c1d6afe21a530d4ec642dee1076bd"></span></div><div class="title-wrapper"><strong class="title">Automakers Targeting Average Households With New Crop Of EVs</strong><em class="description">In their first rollouts of electric vehicles, America&#039;s automakers targeted people who value short-range economy cars. Then came EVs for luxury buyers and drivers of pickups and delivery vans.</em></div><time datetime="2022-07-19T17:53:00+00:00" title="July 19, 2022 at 1:53 pm">21 hours ago</time></a><a href="https://cwdetroit.cbslocal.com/video/6267173-ketchup-bottles-removed-at-heinz-field-after-michigan-based-company-buys-naming-rights/" title="Ketchup Bottles Removed At Heinz Field After Michigan-Based Company Buys Naming Rights" class="cbs-thumbnail-link item-1658242140 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://h101675-ecdn.mp.lura.live/1/998160/anv-pvw/598/630/598630B7DCAD28A751CF14D188DC055E_6.jpg?aktaexp=2082787200&#038;aktasgn=e63f23a135b245c129e842d7c64b96d9"></span></div><div class="title-wrapper"><strong class="title">Ketchup Bottles Removed At Heinz Field After Michigan-Based Company Buys Naming Rights</strong><em class="description">On Monday, July 18, 2022, the Heinz Field signage began coming down at the newly named Acrisure Stadium after the Steelers confirmed a new partnership with the Michigan-based financial technology company Acrisure on July 12, 2022.</em></div><time datetime="2022-07-19T14:49:00+00:00" title="July 19, 2022 at 10:49 am">1 day ago</time></a></div>
</div></div><div id="embed-list-7" class="embed-item embed-list enable-type-icons column-count-3 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Community Affairs</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/video/6267135-community-connect-segments-youthworks-detroit/" title="Community Connect Segments - YouthWorks-Detroit" class="cbs-thumbnail-link item-1657971000 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://m101675-ucdn.mp.lura.live/anv-iupl/472/515/472515C02D7B82770D013656699F1003.jpg?Expires=2082758400&#038;KeyName=mcpkey1&#038;Signature=QeaEaaCAF74U-QWiTOGWGvxkScE"></span></div><div class="title-wrapper"><strong class="title">Community Connect Segments - YouthWorks-Detroit</strong><em class="description">On this week&#039;s Community Connect – From the Riverwalk to the neighborhoods - we see what Summer has in store for Detroit - Watch Saturday 7am on CW50.</em></div><time datetime="2022-07-16T11:30:00+00:00" title="July 16, 2022 at 7:30 am">4 days ago</time></a><a href="https://cwdetroit.cbslocal.com/video/6262854-community-connect-segments-friendship-circle/" title="Community Connect Segments - Friendship Circle" class="cbs-thumbnail-link item-1657366200 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://m101675-ucdn.mp.lura.live/anv-iupl/FCC/4D9/FCC4D90C9637CEB3D8420F82108C592F.jpg?Expires=2082758400&#038;KeyName=mcpkey1&#038;Signature=Uv3pj3I2gbWrWpludwJpkozivGQ"></span></div><div class="title-wrapper"><strong class="title">Community Connect Segments - Friendship Circle</strong><em class="description">On this week&#039;s Community Connect – Organizations instilling confidence in people with intellectual disabilities through sports – Watch Saturday 7am on CW50.</em></div><time datetime="2022-07-09T11:30:00+00:00" title="July 9, 2022 at 7:30 am">11 days ago</time></a><a href="https://cwdetroit.cbslocal.com/video/6260072-community-connect-segments-detroit-pal-officer-bryant-george/" title="Community Connect Segments - Detroit PAL Officer Bryant George" class="cbs-thumbnail-link item-1656761400 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://m101675-ucdn.mp.lura.live/anv-iupl/200/AF4/200AF47584079FD84931492E15C855D4.jpg?Expires=2082758400&#038;KeyName=mcpkey1&#038;Signature=zJYF8o6r1ZJ3aXHGBdnjJmGFu7M"></span></div><div class="title-wrapper"><strong class="title">Community Connect Segments - Detroit PAL Officer Bryant George</strong><em class="description">On this week&#039;s Community Connect – we honor freedom, Detroit style! as we enter this 4th of July weekend – Watch Saturday 7am on CW50.</em></div><time datetime="2022-07-02T11:30:00+00:00" title="July 2, 2022 at 7:30 am">18 days ago</time></a></div>
</div></div></div></div></li><li class="menu-top-item item-6 w-link"><a href="http://detroit.cbslocal.com/" title="CBS Detroit" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CBS Detroit</strong></div></a></li></ul></nav>
	<ul id="live"><li class="menu-item item-0"><a href="/live/channel/wwj-tv/" title="WWJ-TV" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">WWJ-TV</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-8" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">10:00 AM</strong><em class="description">Let's Make a Deal</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">11:00 AM</strong><em class="description">The Price Is Right</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">12:00 PM</strong><em class="description">Family Feud</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">12:30 PM</strong><em class="description">The Young and the Restless</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">1:30 PM</strong><em class="description">The Bold and the Beautiful</em></div></div></div>
</div></div><a class="view-all" href="https://detroit.cbslocal.com/program-guide/">View All Programs</a></div></div></li><li class="menu-item item-1"><a href="/live/channel/wkbd-tv/" title="WKBD-TV" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">WKBD-TV</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-9" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">10:00 AM</strong><em class="description">Let's Make a Deal</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">11:00 AM</strong><em class="description">The Price Is Right</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">12:00 PM</strong><em class="description">Family Feud</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">12:30 PM</strong><em class="description">The Young and the Restless</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">1:30 PM</strong><em class="description">The Bold and the Beautiful</em></div></div></div>
</div></div><a class="view-all" href="https://cwdetroit.cbslocal.com/program-guide/">View All Programs</a></div></div></li></ul>
	
	<div id="info-search"><form action="https://cwdetroit.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size='[[970,250],[970,66],[728,90]]' data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">Mom Stabbed By Son, Jonathan Welch, Becomes 3rd Person To Die In Family Attack</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">July 20, 2022 at 9:40 am</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://cwdetroit.cbslocal.com/tag/family-attack/">family attack</a>, <a href="https://cwdetroit.cbslocal.com/tag/flossie-bray/">Flossie Bray</a>, <a href="https://cwdetroit.cbslocal.com/tag/harper-woods/">Harper Woods</a>, <a href="https://cwdetroit.cbslocal.com/tag/jonathan-welch/">Jonathan Welch</a>, <a href="https://cwdetroit.cbslocal.com/tag/robert-bray/">Robert Bray</a>, <a href="https://cwdetroit.cbslocal.com/tag/zlayiah-frazier/">Zlayiah Frazier</a></div></div></section><section id="column_block_10" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato-program  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"6267520","autoplay":true,"titleVisible":false,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5","customMetadata":{"video":{"cbs_market":"cwdetroit.cbslocal.com","cbs_platform":"desktop"}}},"comscore":{"clientId":"3000023","c3":"cwdetroit.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/cw.det&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/cbsloc.al\/3cy836k","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5,"recom":true,"maxRecomPages":3});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>HARPER WOODS, Mich. (AP)</strong> — A third person has died, days after a Detroit-area man released on bond in a domestic violence case was accused of attacking his girlfriend and family, authorities said.<p>
<div id="attachment_1094514" style="width: 235px" class="wp-caption alignright"><img aria-describedby="caption-attachment-1094514" loading="lazy" class="size-medium wp-image-1094514" src="https://detroit.cbslocal.com/wp-content/uploads/sites/15909782/2022/06/Jonathan-Welch.jpg?w=225" alt="" width="225" height="300"><p id="caption-attachment-1094514" class="wp-caption-text">Jonathan Welch (credit: Detroit Police Department)</p></div>
</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://cwdetroit.cbslocal.com/2022/07/20/police-seek-suspect-who-allegedly-hit-victim-with-his-car-in-detroit/" target="_blank">Police Seek Suspect Who Allegedly Hit Victim With His Car In Detroit</a><p>Flossie Bray, who was repeatedly stabbed on June 10, died over the weekend, family members said.</p><p>Her son, Jonathan Welch, is in custody on murder and other charges, which are likely to be changed after Bray’s death.</p><p>Welch’s girlfriend, Zlayiah Frazier, 22, and stepfather, Robert Bray Jr., 70, were also killed at Welch’s Harper Woods home.</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://cwdetroit.cbslocal.com/2022/07/20/judge-strikes-2018-michigan-gop-effort-to-attack-minimum-wage-hike/" target="_blank">Judge Strikes 2018 Michigan GOP Effort To Attack Minimum Wage Hike</a><p>A standoff with police lasted seven hours.</p><p>Welch, 23, was charged in June with assaulting Frazier and committing other crimes. He was eventually released after posting 10% of a $100,000 bond.</p><p>Welch has another court hearing Wednesday.</p><strong style="color: black; float: left; padding-right: 5px;">MORE NEWS: </strong><a style="display: block; margin-bottom: 25px;" href="https://cwdetroit.cbslocal.com/2022/07/20/12-year-old-shot-killed-by-13-year-old-in-detroit-home/" target="_blank">12-Year-Old Shot, Killed By 13-Year-Old In Detroit Home</a><p><em>© 2022 Associated Press. All Rights Reserved. This material may not be published, broadcast, rewritten, or redistributed.</em></p></p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3cy836k"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3cy836k"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3cy836k"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size='[[1,5],"fluid"]' data-ad_location="partner-injected"><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-11"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size='[[300,250],[300,600],[300,1050]]' data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://www.facebook.com/cw50detroit" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/cw50detroit" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
<li><a href="https://cwdetroit.cbslocal.com/2022/07/19/mdot-reminds-drivers-i-94-in-detroit-will-be-closed-for-7-days-starting-july-22/" title="MDOT Reminds Drivers I-94 In Detroit Will Be Closed For 7 Days Starting July 22" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/GettyImages-532912877-3.jpg?resize=55%2C55&#038;ssl=1" alt="MDOT Reminds Drivers I-94 In Detroit Will Be Closed For 7 Days Starting July 22" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/07/19/mdot-reminds-drivers-i-94-in-detroit-will-be-closed-for-7-days-starting-july-22/" title="MDOT Reminds Drivers I-94 In Detroit Will Be Closed For 7 Days Starting July 22" class="bump-view" data-bump-view="tp">MDOT Reminds Drivers I-94 In Detroit Will Be Closed For 7 Days Starting July 22</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/07/18/lottery-ticket-worth-25k-a-year-for-life-purchased-in-battle-creek/" title="Lottery Ticket Worth $25K A Year For Life Purchased In Battle Creek" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/173666571-e1543847082548.jpg?resize=55%2C55&#038;ssl=1" alt="Lottery Ticket Worth $25K A Year For Life Purchased In Battle Creek" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/07/18/lottery-ticket-worth-25k-a-year-for-life-purchased-in-battle-creek/" title="Lottery Ticket Worth $25K A Year For Life Purchased In Battle Creek" class="bump-view" data-bump-view="tp">Lottery Ticket Worth $25K A Year For Life Purchased In Battle Creek</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/07/18/the-trial-of-murphy-mason-part-two-in-the-dark/" title="The Trial of Murphy Mason, Part Two - In The Dark" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/ITD-7.18.jpg?resize=55%2C55&#038;ssl=1" alt="The Trial of Murphy Mason, Part Two - In The Dark" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/07/18/the-trial-of-murphy-mason-part-two-in-the-dark/" title="The Trial of Murphy Mason, Part Two - In The Dark" class="bump-view" data-bump-view="tp">The Trial of Murphy Mason, Part Two - In The Dark</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/07/18/5-arrested-after-entering-store-in-flint-with-rifles/" title="5 Arrested After Entering Store In Flint With Rifles" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/shutterstock_1191163906-6.jpg?resize=55%2C55&#038;ssl=1" alt="5 Arrested After Entering Store In Flint With Rifles" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/07/18/5-arrested-after-entering-store-in-flint-with-rifles/" title="5 Arrested After Entering Store In Flint With Rifles" class="bump-view" data-bump-view="tp">5 Arrested After Entering Store In Flint With Rifles</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/07/19/michigan-reports-16445-new-covid-19-cases-149-deaths-over-the-last-week/" title="Michigan Reports 16,445 New COVID-19 Cases, 149 Deaths Over The Last Week" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/shutterstock_1624635628-3.jpg?resize=55%2C55&#038;ssl=1" alt="Michigan Reports 16,445 New COVID-19 Cases, 149 Deaths Over The Last Week" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/07/19/michigan-reports-16445-new-covid-19-cases-149-deaths-over-the-last-week/" title="Michigan Reports 16,445 New COVID-19 Cases, 149 Deaths Over The Last Week" class="bump-view" data-bump-view="tp">Michigan Reports 16,445 New COVID-19 Cases, 149 Deaths Over The Last Week</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/07/19/heres-where-state-abortion-bans-stand-amid-legal-challenges/" title="Here&#039;s Where State Abortion Bans Stand Amid Legal Challenges" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/hypatia-h_2793195df6dcd8663affa06f1fbef2f5-h_cb107a037857c83cb3a20408c2cc5d60.jpg?resize=55%2C55&#038;ssl=1" alt="Here&#039;s Where State Abortion Bans Stand Amid Legal Challenges" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/07/19/heres-where-state-abortion-bans-stand-amid-legal-challenges/" title="Here&#039;s Where State Abortion Bans Stand Amid Legal Challenges" class="bump-view" data-bump-view="tp">Here&#039;s Where State Abortion Bans Stand Amid Legal Challenges</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2021/03/03/detroit-zoo-polar-bear-takes-her-first-steps-in-snow-and-it-is-adorable/" title="Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/03/snapshot-25.jpg?resize=55%2C55&#038;ssl=1" alt="Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2021/03/03/detroit-zoo-polar-bear-takes-her-first-steps-in-snow-and-it-is-adorable/" title="Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!" class="bump-view" data-bump-view="tp">Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/07/19/ketchup-bottles-removed-at-heinz-field-after-michigan-based-company-buys-naming-rights/" title="Ketchup Bottles Removed At Heinz Field After Michigan-Based Company Buys Naming Rights" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/07/598630B7DCAD28A751CF14D188DC055E_6.jpg?resize=55%2C55&#038;ssl=1" alt="Ketchup Bottles Removed At Heinz Field After Michigan-Based Company Buys Naming Rights" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/07/19/ketchup-bottles-removed-at-heinz-field-after-michigan-based-company-buys-naming-rights/" title="Ketchup Bottles Removed At Heinz Field After Michigan-Based Company Buys Naming Rights" class="bump-view" data-bump-view="tp">Ketchup Bottles Removed At Heinz Field After Michigan-Based Company Buys Naming Rights</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2018/12/03/detroit-proud-playlist-week-of-12-3/" title="Detroit Proud Playlist: Week of 12/3" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2013/07/dpplaylistimage2.jpg?resize=55%2C55&#038;ssl=1" alt="Detroit Proud Playlist: Week of 12/3" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2018/12/03/detroit-proud-playlist-week-of-12-3/" title="Detroit Proud Playlist: Week of 12/3" class="bump-view" data-bump-view="tp">Detroit Proud Playlist: Week of 12/3</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/06/29/crime-without-punishment-detroit-homicide-clearance-rates-rise-as-national-rates-fall/" title="Crime Without Punishment: Detroit Homicide Clearance Rates Rise as National Rates Fall" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/CleanShot-2022-06-29-at-14.40.png?resize=55%2C55&#038;ssl=1" alt="Crime Without Punishment: Detroit Homicide Clearance Rates Rise as National Rates Fall" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/06/29/crime-without-punishment-detroit-homicide-clearance-rates-rise-as-national-rates-fall/" title="Crime Without Punishment: Detroit Homicide Clearance Rates Rise as National Rates Fall" class="bump-view" data-bump-view="tp">Crime Without Punishment: Detroit Homicide Clearance Rates Rise as National Rates Fall</a>
							</div>
							</li></ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size='[[300,250]]' data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size='[[728,90]]' data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://cwdetroit.cbslocal.com" class="logo"><img src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2015/09/cw50_230x86.png" alt="CW50 Detroit" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/cw50detroit" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/cw50detroit" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
	
			<section class="bottom"><div class="wrapper">
			<a href="https://cwdetroit.cbslocal.com" class="logo"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-viacom-logo-white.png" alt="CW50 Detroit" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2022 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=cwdetroit.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
							</div>

			<div class="right-wrapper">
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-262"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-263"><a href="https://www.viacomcbsprivacy.com/policy">Privacy Policy</a></li>
<li id="menu-item-52919" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52919"><a href="https://www.viacomcbsprivacy.com/donotsell">Do Not Sell My Persoanl Information</a></li>
<li id="menu-item-68537" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68537"><a href="https://www.viacomcbsprivacy.com/cookies">Cookies Policy</a></li>
<li id="menu-item-264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264"><a href="http://cwdetroit.cbslocal.com/contact-us/">Contact Us</a></li>
<li id="menu-item-16485" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16485"><a href="http://publicfiles.fcc.gov/tv-profile/WKBD-TV">Public File for WKBD-TV / CW50 Detroit</a></li>
<li id="menu-item-49756" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49756"><a href="http://policies.cbslocal.com/fcc/detroit.television.contact.html">Public File Contact Us for WKBD-TV / CW50 Detroit</a></li>
<li id="menu-item-60381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60381"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-60380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60380"><a href="https://cwdetroit.cbslocal.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-10825" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10825"><a href="http://cbsdetroit.com/eeo">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size='[[1,8]]' data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size='[[1,6]]' data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size='[[1,7]]' data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='screen-css-0' href='https://cwdetroit.cbslocal.com/_static/??-eJzTLy/QTc7PK0nNK9EvyUjNTS3WT04q1s3JT07M0c/MS84pTQEKpeYmpaYAZYqhTN2czOISPSBXR598/brpRZkpFBuSnJ9bkJgMdox9rq2hmamZsbGluZEJAIjVT2g=' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1656339724g' type='text/css' media='all' />
<script type="text/javascript" src="https://cwdetroit.cbslocal.com/_static/??-eJx9jEsSgjAMQC9kiQx+2DieBWjE1DRhklaH28u4csX6feCzBJKJa0SH5BDJC7xRohoYzihoQ1ELVqVQxiaTNMkPsJNtaFFeH8S8qz9VX/5vTCoFpUCuYeE6k/jvNZgjr6FrOhgrcQTWIaJt1T3f2sv5ejz1fdunL19ISeU=" ></script><script data-parsely-site="cwdetroit.cbslocal.com" src='https://cdn.parsely.com/keys/cwdetroit.cbslocal.com/p.js?ver=3.3.2' id="parsely-cfg"></script>
<script type="text/javascript" src="https://cwdetroit.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1653937220g" ></script><script src='https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js?ver=5.8.4' id='cbs-cbs-anvato-js'></script>
<script src='https://stats.wp.com/e-202229.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'162246157',post:'94708',tz:'-4',srv:'cwdetroit.cbslocal.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '162246157', '94708' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>