<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://cwdetroit.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="keywords" content="community, news, syndicated local, ticker, juneteenth, juneteenth events, metro detroit" />
<meta property="fb:pages" content="245397755489628" />
<title>Celebrate Juneteenth This Weekend At These Events In Metro Detroit &#8211; CW50 Detroit</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.mp.lura.live' />
<link rel='dns-prefetch' href='//cdn.parsely.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="CW50 Detroit &raquo; Feed" href="https://cwdetroit.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://cwdetroit.cbslocal.com/_static/??-eJytj0sOwjAMRC9EMIgGVoizpIkpUR07yke9PiFlwwoqsbI99huNYYnKChfkAuWBATPYMSsSawg8W6ruJeUMd5GCad/aHfwEYRjRrWxMSGLcdzhSnTxnCOIqtY15G7S6He4HKhg2E6Zu86GoFnIuEje8tHrUMLLxpMjz/P9USG3i0v+9hevxrAd9OgwX/QR1iZ9Z' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://cwdetroit.cbslocal.com/_static/??-eJytU9tOwzAM/SGybKIF8YD4ljS1umzORYm7qn8/p3SUUmAt4i2+nGMfO5ZdENo7AkeSjmAhSV0lgV4rlIl6hJ1O6UH+lmacxrbOrpRkUA0IAhtQ0QpshgCy01G6nx2wbYxL0vq6RY4MCcIqx0XjwEV9gGJjy52pp5ZXdPFFb/xL5+noI2l/Y5nMDeXBVlC/44enQJNIaEUKfbNRBqswGkFcpuHN4jVTy4qBZ65SRRX78XdY45aIEwuF2qhxszODp9xDFAiN0v06OMc+2zPQ6onzlhugj43n94LEtuIGOwEFxWoP+93LgoN8EMEnfq08kfsf16p4ztTjWXj08V8OYs7rLxC7aL65zJ+kZ47RkTFv9vXwVBbl4754Lq9WSJb4' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type="text/javascript" src="https://cwdetroit.cbslocal.com/_static/??-eJy1UMsOwjAM+yG68NjghPiW0mWjJU3LmoL295SJA7sNJE5WHNuxAo+oTGBBFpALekxgzklRMJrAsqHcFsoliIHGzhJV3nLl0gqWGt0iR6TcW07gQ5upbHQ7mQuo+/YzYRZ9yziMb1gkUt72gxb8qdMkUF6z7nF4Rc8IVe5dJcSvntNlNmIDp38UQioTSyq5J3/c7Ju62a3rQ+OesNy6Og==" ></script><script src='https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js?ver=5.8.4' id='partner__video__anvato-js'></script>
<script type="text/javascript" src="https://cwdetroit.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILSBWOCG+pUujLlXaTiTdfp8KceHCbpb9bMO+DliLUTGwhTIp4KyDVPQCXFBa6FZS8GEh5Y3GzGVMeoJ/xc5HqbOXQ/Ln4mWMQoedVVrkopBraNKTnUMk+0x8ZZ945sfl5iZ3PU93l94KvlTS" ></script><link rel="https://api.w.org/" href="https://cwdetroit.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://cwdetroit.cbslocal.com/wp-json/wp/v2/posts/91793" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cwdetroit.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cwdetroit.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.4" />
<link rel='shortlink' href='https://cbsloc.al/3QBYRxg' />
<link rel="alternate" type="application/json+oembed" href="https://cwdetroit.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcwdetroit.cbslocal.com%2F2022%2F06%2F16%2Fcelebrate-juneteenth-at-these-events-in-metro-detroit%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://cwdetroit.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcwdetroit.cbslocal.com%2F2022%2F06%2F16%2Fcelebrate-juneteenth-at-these-events-in-metro-detroit%2F&#038;format=xml" />
<meta name="parsely-title" content="Celebrate Juneteenth This Weekend At These Events In Metro Detroit" />
<meta name="parsely-link" content="http://cwdetroit.cbslocal.com/2022/06/16/celebrate-juneteenth-at-these-events-in-metro-detroit/" />
<meta name="parsely-type" content="post" />
<meta name="parsely-image-url" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/GettyImages-1233552451.jpg?w=150&amp;h=150&amp;crop=1" />
<meta name="parsely-pub-date" content="2022-06-16T19:16:21Z" />
<meta name="parsely-section" content="Community" />
<meta name="parsely-tags" content="juneteenth,juneteenth events,metro detroit" />
<meta name="parsely-author" content="cbslocaladmin" />
<style type='text/css'>img#wpstats{display:none}</style>
	
<meta property="og:title" content="Celebrate Juneteenth This Weekend At These Events In Metro Detroit" /><meta property="og:image" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/GettyImages-1233552451.jpg?w=1500" /><meta property="og:image:secure_url" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/GettyImages-1233552451.jpg?w=1500" /><meta property="og:image:width" content="1500" /><meta property="og:image:height" content="967" /><meta property="og:description" content="Communities across Metro Detroit will celebrate Juneteenth this weekend with events with music, film and other activities." /><meta property="og:type" content="article" /><meta property="og:url" content="https://cwdetroit.cbslocal.com/2022/06/16/celebrate-juneteenth-at-these-events-in-metro-detroit/" /><meta property="article:published_time" content="2022-06-16T15:16:21+00:00" /><meta property="article:suggested-social-copy" content="Communities across Metro Detroit will celebrate Juneteenth this weekend with events with music, film and other activities." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Community,News,Syndicated Local,Ticker" /><meta property="article:publisher" content="http://www.facebook.com/cw50detroit" /><meta property="article:author" content="http://www.facebook.com/cw50detroit" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/GettyImages-1233552451.jpg?w=1500"><meta name="twitter:title" content="Celebrate Juneteenth This Weekend At These Events In Metro Detroit"/><meta name="twitter:description" content="Communities across Metro Detroit will celebrate Juneteenth this weekend with events with music, film and other activities."/><meta name="twitter:site" content="/cw50detroit"/>
<link rel="canonical" href="https://cwdetroit.cbslocal.com/2022/06/16/celebrate-juneteenth-at-these-events-in-metro-detroit/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://cwdetroit.cbslocal.com/2022/06/16/celebrate-juneteenth-at-these-events-in-metro-detroit/?amp">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/cwdetroit.cbslocal.com","url":"https:\/\/cwdetroit.cbslocal.com","name":"CW50 Detroit","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/cwdetroit.cbslocal.com\/wp-content\/uploads\/sites\/31326028\/2018\/07\/4_detroit_cw50.png?w=158"}},"url":"https:\/\/cwdetroit.cbslocal.com\/2022\/06\/16\/celebrate-juneteenth-at-these-events-in-metro-detroit\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/cwdetroit.cbslocal.com\/2022\/06\/16\/celebrate-juneteenth-at-these-events-in-metro-detroit\/"},"headline":"Celebrate Juneteenth This Weekend At These Events In Metro Detroit","description":"Communities across Metro Detroit will celebrate Juneteenth this weekend with events with music, film and other activities.","image":"https:\/\/cwdetroit.cbslocal.com\/wp-content\/uploads\/sites\/31326028\/2022\/06\/GettyImages-1233552451.jpg?w=1500","keywords":["Community","News","Syndicated Local","Ticker","Juneteenth","Juneteenth events","Metro Detroit","news","Celebrate Juneteenth This Weekend At These Events In Metro Detroit"],"datePublished":"2022-06-16T15:16:21+00:00","dateModified":"2022-06-16T15:16:21+00:00","author":{"@type":"Organization","name":"CW50 Detroit"},"video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"Over 2.9M Ford Vehicles Recalled Due To Risk Of Roll Away Crashes","description":"Ford is recalling over 2.9 million vehicles to fix a transmission problem that can increase the risk of inadvertent rollaway crashes.","thumbnailUrl":"https:\/\/m101675-ucdn.mp.lura.live\/anv-iupl\/85B\/C6E\/85BC6E5E77786FAECBCF8EA2E9BC0D9E.jpg?Expires=2082758400&KeyName=mcpkey1&Signature=D7cnkC10Z5G0DRptkK06mUfjAfA","uploadDate":"2022-06-16","duration":"T25S","contentUrl":"https:\/\/cwdetroit.cbslocal.com\/video\/6253442-over-2-9m-ford-vehicles-recalled-due-to-risk-of-roll-away-crashes\/","embedUrl":"https:\/\/cwdetroit.cbslocal.com\/video\/6253442-over-2-9m-ford-vehicles-recalled-due-to-risk-of-roll-away-crashes\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script>
<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CW.DET","news",["celebratejuneteenththisweekendattheseeventsinmetrodetroit","post","article","community","news","syndicatedlocal","ticker","juneteenth","juneteenthevents","metrodetroit","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("2");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-64" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-64" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"community;news;syndicated-local;ticker;","dimension2":"article"});gtag("config","UA-2438645-64");</script>

<!-- WP Header - End -->

	<meta name="description" content="Communities across Metro Detroit will celebrate Juneteenth this weekend with events with music, film and other activities." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-91793 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://cwdetroit.cbslocal.com" id="header-logo"><img src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2018/07/4_detroit_cw50.png?w=158" alt="CW50 Detroit" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Latest Update</strong></div></div><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list enable-type-icons column-count-3 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">News</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/2022/06/15/michigan-reports-15578-new-covid-19-cases-137-deaths-over-the-last-week/" title="Michigan Reports 15,578 New COVID-19 Cases, 137 Deaths Over The Last Week" class="cbs-thumbnail-link item-1655322312" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/shutterstock_1624635628-3.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Michigan Reports 15,578 New COVID-19 Cases, 137 Deaths Over The Last Week</strong><em class="description">The Michigan Department of Health and Human Services announced new coronavirus cases and additional deaths in the state. Here&#039;s everything to know.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/06/14/keeping-pets-safe-in-the-summer-signs-of-heat-exhaustion/" title="Keeping Pets Safe In The Summer; Here Are Signs of Heat Exhaustion" class="cbs-thumbnail-link item-1655247653" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/ZION-PRESSER-VO.00_00_10_03.Still001.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Keeping Pets Safe In The Summer; Here Are Signs of Heat Exhaustion</strong><em class="description">Handlers at the Michigan Animal Rescue League says it&#039;s important to watch out for signs of heat exhaustion.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/06/13/inflation-on-a-fixed-income-focus-hope-steps-in-to-help-seniors/" title="Inflation On A Fixed Income, FOCUS Hope Steps In To Help Seniors" class="cbs-thumbnail-link item-1655161340" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/CW50-SENIORS-INFLATION.00_00_43_29.Still001.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Inflation On A Fixed Income, FOCUS Hope Steps In To Help Seniors</strong><em class="description">Thousands of seniors across Southeastern Michigan are experiencing hard times and FOCUS Hope is stepping-in to fill that gap by filling up their pantries.</em></div></a></div>
</div></div><div id="embed-list-2" class="embed-item embed-list enable-type-icons column-count-1 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Eye on Detroit</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/2021/09/01/dutton-farm/" title="The Mission of Dutton Farm" class="cbs-thumbnail-link item-1630549843 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/02/dutton.jpg?w=625&#038;h=352&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">The Mission of Dutton Farm</strong><em class="description">Changing The Future of Possibilities For People With Disabilities</em></div></a></div>
</div></div><div id="embed-list-3" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Coming Up</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/2022/06/13/a-matter-of-miles-walker/" title="A Matter of Miles - Walker" class="cbs-thumbnail-link item-1655093292" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/WLK-6.16.jpg?w=627&#038;h=352&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">A Matter of Miles - Walker</strong><em class="description">Stella and Colton plan a Walker / Davidson family dinner.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/06/13/just-dont-be-a-stranger-okay-legacies/" title="Just Don’t Be A Stranger, Okay? - Legacies" class="cbs-thumbnail-link item-1655093255" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/LGC-6.16.jpg?w=627&#038;h=353&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Just Don’t Be A Stranger, Okay? - Legacies</strong><em class="description">Hope, Lizzie, MG, Kaleb, Jed, Cleo, and Alaric reflect on recent events and what comes next for each of them. </em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://cwdetroit.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-4" class="embed-item embed-list enable-type-icons column-count-6 block-type-grid" ><div class="wrapper">
<div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/2022/06/16/police-investigate-after-man-shot-killed-in-detroit/" title="Police Investigate After Man Shot, Killed In Detroit" class="cbs-thumbnail-link item-1655412474" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/shutterstock_1191163906-7.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Police Investigate After Man Shot, Killed In Detroit</strong><em class="description">Police are investigating a shooting that left one man dead Thursday morning in Detroit.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/06/16/western-michigan-university-mens-basketball-players-hit-the-court-with-beautiful-lives-project/" title="Western Michigan University Men&#039;s Basketball Players Hit The Court With Beautiful Lives Project" class="cbs-thumbnail-link item-1655408239" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/423B011E3294E776D3757042B97B8514_2.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Western Michigan University Men&#039;s Basketball Players Hit The Court With Beautiful Lives Project</strong><em class="description">The Beautiful Lives Project aims to give people with disabilities the opportunity to take part in activities they normally wouldn’t get the chance to.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/06/16/celebrate-juneteenth-at-these-events-in-metro-detroit/" title="Celebrate Juneteenth This Weekend At These Events In Metro Detroit" class="cbs-thumbnail-link item-1655406981" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/GettyImages-1233552451.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Celebrate Juneteenth This Weekend At These Events In Metro Detroit</strong><em class="description">Communities across Metro Detroit will celebrate Juneteenth this weekend with events with music, film and other activities.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/06/16/uwm-sports-complex-in-pontiac-to-host-career-fair-on-june-23/" title="UWM Sports Complex In Pontiac To Host Career Fair On June 23" class="cbs-thumbnail-link item-1655404253" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/GettyImages-155439015.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">UWM Sports Complex In Pontiac To Host Career Fair On June 23</strong><em class="description">This career expo will provide students and residents in Pontiac and the Metro Detroit area with the opportunity to meet recruiters from local and regional organizations. </em></div></a><a href="https://cwdetroit.cbslocal.com/2022/06/16/state-police-seize-more-than-100k-worth-of-drugs-arrest-3-in-detroit/" title="State Police Seize More Than $100K Worth Of Drugs, Arrest 3 In Detroit" class="cbs-thumbnail-link item-1655399363" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/FVYXnQCVUAIF7GF.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">State Police Seize More Than $100K Worth Of Drugs, Arrest 3 In Detroit</strong><em class="description">Michigan State Police say a criminal investigation in Detroit resulted in confiscating more than $100,000 worth of drugs and three arrests.</em></div></a><a href="https://cwdetroit.cbslocal.com/2022/06/16/michigan-initiatives-miss-deadline-will-look-to-legislature/" title="Michigan Initiatives Miss Deadline, Will Look To Legislature" class="cbs-thumbnail-link item-1655396654" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/GettyImages-155370094-2.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Michigan Initiatives Miss Deadline, Will Look To Legislature</strong><em class="description">Organizers behind two high-profile proposed laws in Michigan skipped a deadline to potentially appear on November’s ballot and will instead look to get the initiatives approved by the Republican-controlled Legislature.</em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-2 w-link"><a href="http://cwdetroit.cbslocal.com/cw-detroit-tv-schedule" title="TV Schedule" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">TV Schedule</strong></div></a></li><li class="menu-top-item item-3 w-link"><a href="http://cwdetroit.cbslocal.com/tag/cw50-street-team/" title="Street Team" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Street Team</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://cwdetroit.cbslocal.com/category/detroit-proud/" title="Detroit Proud" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Detroit Proud</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-5" class="embed-item embed-list enable-type-icons column-count-6 block-type-grid" ><div class="wrapper">
<div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/2020/02/24/detroit-proud-playlist-hamtramck-music-festival/" title="Detroit Proud Playlist: Hamtramck Music Festival" class="cbs-thumbnail-link item-1582565278" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Hamtramck Music Festival</strong><em class="description">The City of Hamtramck comes alive with art, culture, and music via the Hamtramck Music Festival, featuring 200 bands playing 24 venues and restaurants.</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/09/04/detroit-proud-playlist-dally-in-the-alley/" title="Detroit Proud Playlist: Dally In The Alley" class="cbs-thumbnail-link item-1567614651" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Dally In The Alley</strong><em class="description">Dally in the Alley is the go-to event of the summer to discover your new favorite local headliner or underground group. Get into the spirit with this week&#039;s Playlist!</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/07/16/detroit-proud-playlist-pig-whiskey-2019/" title="Detroit Proud Playlist: Pig &amp; Whiskey 2019" class="cbs-thumbnail-link item-1563305958" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Pig &amp; Whiskey 2019</strong><em class="description">Pig &amp; Whiskey Festival encapsulates a Michigan summer in one weekend. We’ve curated a schedule with an eclectic mix of bands that pairs well with any kind of BBQ, brew, or whiskey that you choose to enjoy alongside the music.</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/03/04/detroit-proud-playlist-hamtramck-music-festival-2019/" title="Detroit Proud Playlist: Hamtramck Music Festival 2019!" class="cbs-thumbnail-link item-1551716768" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Hamtramck Music Festival 2019!</strong><em class="description">It&#039;s that time of year again! We’ve selected an eclectic mix of can’t-miss bands playing this weekend&#039;s Hamtramck Music Festival for this week&#039;s Detroit Proud Playlist!</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/02/18/detroit-proud-playlist-guest-dj-vazum-frontman-zach-pliska/" title="Detroit Proud Playlist: Guest DJ - VAZUM Frontman Zach Pliska!" class="cbs-thumbnail-link item-1550466084" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2013/08/dpplaylistimage2.jpg?w=478&#038;h=359&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Guest DJ - VAZUM Frontman Zach Pliska!</strong><em class="description">This week, we have a special Guest DJ-ed playlist, curated by VAZUM frontman Zach Pliska! Zach put his own spin on our Detroit Proud Playlist this week - check out his picks below!</em></div></a><a href="https://cwdetroit.cbslocal.com/2018/12/03/detroit-proud-playlist-week-of-12-3/" title="Detroit Proud Playlist: Week of 12/3" class="cbs-thumbnail-link item-1543848574" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2013/07/dpplaylistimage2.jpg?w=478&#038;h=359&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Week of 12/3</strong><em class="description">The playlist is here for another week of Detroit music! We have new tunes, old tunes, and a little something for everyone. Check it out!</em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-5 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></div><div class="submenu"><div class="wrapper"><div id="embed-list-6" class="embed-item embed-list enable-type-icons column-count-3 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="http://cwdetroit.cbslocal.com/video/category/spoken-word-wkbdtv/">News</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/video/6253713-western-michigan-university-mens-basketball-players-hit-the-court-with-beautiful-lives-project/" title="Western Michigan University Men&#039;s Basketball Players Hit The Court With Beautiful Lives Project" class="cbs-thumbnail-link item-1655407560 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://h101675-ecdn.mp.lura.live/1/998160/anv-pvw/423/B01/423B011E3294E776D3757042B97B8514_2.jpg?aktaexp=2082787200&#038;aktasgn=037d5cac9bc9f0db803addf3a0229c9a"></span></div><div class="title-wrapper"><strong class="title">Western Michigan University Men&#039;s Basketball Players Hit The Court With Beautiful Lives Project</strong><em class="description">The Beautiful Lives Project aims to give people with disabilities the opportunity to take part in activities they normally wouldn’t get the chance to.</em></div><time datetime="2022-06-16T19:26:00+00:00" title="June 16, 2022 at 3:26 pm">1 hour ago</time></a><a href="https://cwdetroit.cbslocal.com/video/6253146-police-seek-suspect-who-shot-man-inside-detroit-laundromat/" title="Police Seek Suspect Who Shot Man Inside Detroit Laundromat" class="cbs-thumbnail-link item-1655311800 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://h101675-ecdn.mp.lura.live/1/998160/anv-pvw/BDF/FBB/BDFFBB3E0A90AD1FE278DF2630F3B4DE_3.jpg?aktaexp=2082787200&#038;aktasgn=732d8e17e432841e6a30227ad8b988cf"></span></div><div class="title-wrapper"><strong class="title">Police Seek Suspect Who Shot Man Inside Detroit Laundromat</strong><em class="description">The Detroit Police Department is seeking a suspect wanted in connection to a non-fatal laundromat shooting.</em></div><time datetime="2022-06-15T16:50:00+00:00" title="June 15, 2022 at 12:50 pm">1 day ago</time></a><a href="https://cwdetroit.cbslocal.com/video/6252694-science-of-weather-wind-turbines/" title="Science of Weather: Wind Turbines" class="cbs-thumbnail-link item-1655232480 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://h101675-ecdn.mp.lura.live/1/998160/anv-pvw/06C/FD8/06CFD83F5828B51B88D349670D1C7F7F_1.jpg?aktaexp=2082787200&#038;aktasgn=56e70351574260b30d2cce4d964db05b"></span></div><div class="title-wrapper"><strong class="title">Science of Weather: Wind Turbines</strong><em class="description">Science of Weather: Wind Turbines</em></div><time datetime="2022-06-14T18:48:00+00:00" title="June 14, 2022 at 2:48 pm">2 days ago</time></a></div>
</div></div><div id="embed-list-7" class="embed-item embed-list enable-type-icons column-count-3 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Community Affairs</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://cwdetroit.cbslocal.com/video/6251459-community-connect-segments-caribbean-community-service-center/" title="Community Connect Segments - Caribbean Community Service Center" class="cbs-thumbnail-link item-1654947000 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://m101675-ucdn.mp.lura.live/anv-iupl/45A/448/45A448210467BCE7182CDF59585EA4D5.jpg?Expires=2082758400&#038;KeyName=mcpkey1&#038;Signature=_SNp0gkrv4PHZZxDzi11O2h88Ak"></span></div><div class="title-wrapper"><strong class="title">Community Connect Segments - Caribbean Community Service Center</strong><em class="description">On this week&#039;s Community Connect – We celebrate the food, culture, and heritage of the Caribbean-American community in Detroit.</em></div><time datetime="2022-06-11T11:30:00+00:00" title="June 11, 2022 at 7:30 am">5 days ago</time></a><a href="https://cwdetroit.cbslocal.com/video/6249662-community-connect-segments-rahi-shah/" title="Community Connect Segments - Rahi Shah" class="cbs-thumbnail-link item-1654342200 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://m101675-ucdn.mp.lura.live/anv-iupl/BC3/C73/BC3C736CDEE8C1BEB8D478B823F5156D.jpg?Expires=2082758400&#038;KeyName=mcpkey1&#038;Signature=OX7T3_OfG7NeFFxPFQMJgva8Gpk"></span></div><div class="title-wrapper"><strong class="title">Community Connect Segments - Rahi Shah</strong><em class="description">On this week&#039;s Community Connect we celebrate PRIDE and inclusion as we hear about the awareness, support and safe spaces being created to ensure everyone can live their true life.</em></div><time datetime="2022-06-04T11:30:00+00:00" title="June 4, 2022 at 7:30 am">12 days ago</time></a><a href="https://cwdetroit.cbslocal.com/video/6245345-community-connect-segments-connections-academy/" title="Community Connect Segments - Connections Academy" class="cbs-thumbnail-link item-1653737400 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://m101675-ucdn.mp.lura.live/anv-iupl/2B0/B50/2B0B50BB833DAD5C6BDBAD6F2CE03714.jpg?Expires=2082758400&#038;KeyName=mcpkey1&#038;Signature=v3yqamcDc-ZAniHPDuCeLgvydrs"></span></div><div class="title-wrapper"><strong class="title">Community Connect Segments - Connections Academy</strong><em class="description">On this week’s Community Connect – Mental Health is important in every stage of our life, from childhood to adulthood. We’re sitting down with three professionals who focus on improving the mental health in athletes, students, and anyone seeking the help they need.</em></div><time datetime="2022-05-28T11:30:00+00:00" title="May 28, 2022 at 7:30 am">19 days ago</time></a></div>
</div></div></div></div></li><li class="menu-top-item item-6 w-link"><a href="http://detroit.cbslocal.com/" title="CBS Detroit" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CBS Detroit</strong></div></a></li></ul></nav>
	<ul id="live"><li class="menu-item item-0"><a href="/live/channel/wwj-tv/" title="WWJ-TV" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">WWJ-TV</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-8" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">4:00 PM</strong><em class="description">The Drew Barrymore Show</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">5:00 PM</strong><em class="description">Dr. Phil</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">6:00 PM</strong><em class="description">Family Feud</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">6:30 PM</strong><em class="description">CBS Evening News with Norah O'Donnell</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">7:00 PM</strong><em class="description">Family Feud</em></div></div></div>
</div></div><a class="view-all" href="https://detroit.cbslocal.com/program-guide/">View All Programs</a></div></div></li><li class="menu-item item-1"><a href="/live/channel/wkbd-tv/" title="WKBD-TV" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">WKBD-TV</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-9" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">4:00 PM</strong><em class="description">The Drew Barrymore Show</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">5:00 PM</strong><em class="description">Dr. Phil</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">6:00 PM</strong><em class="description">Family Feud</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">6:30 PM</strong><em class="description">CBS Evening News with Norah O'Donnell</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">7:00 PM</strong><em class="description">Family Feud</em></div></div></div>
</div></div><a class="view-all" href="https://cwdetroit.cbslocal.com/program-guide/">View All Programs</a></div></div></li></ul>
	
	<div id="info-search"><form action="https://cwdetroit.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size='[[970,250],[970,66],[728,90]]' data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">Celebrate Juneteenth This Weekend At These Events In Metro Detroit</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">June 16, 2022 at 3:16 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://cwdetroit.cbslocal.com/tag/juneteenth/">Juneteenth</a>, <a href="https://cwdetroit.cbslocal.com/tag/juneteenth-events/">Juneteenth events</a>, <a href="https://cwdetroit.cbslocal.com/tag/metro-detroit/">Metro Detroit</a></div></div></section><section id="column_block_10" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato-program  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"6253442","autoplay":true,"titleVisible":false,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5","customMetadata":{"video":{"cbs_market":"cwdetroit.cbslocal.com","cbs_platform":"desktop"}}},"comscore":{"clientId":"3000023","c3":"cwdetroit.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/cw.det&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/cbsloc.al\/3QBYRxg","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5,"recom":true,"maxRecomPages":3});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>(CBS DETROIT) &#8212;</strong> Juneteenth, which became a federal holiday in 2021, commemorates the end of slavery in the United States.</p>
<p>Communities across Metro Detroit will celebrate Juneteenth this weekend with events with music, film and other activities.</p>
<p>Here is a list of events happening this weekend in honor of the annual holiday.</p>
<h3>Dearborn</h3>
<ul>
<li><strong>June 18:</strong> <a href="https://www.apridetroitdownriver.org/upcoming-events/2022/5/13/2022-juneteenth-celebration" rel="nofollow">Juneteenth Celebration</a>
<ul>
<li>9 a.m. to 3 p.m. at UAW Local 600, 10550 Dix Ave.
<ul>
<li>The free event will feature educators, speakers, poets, musicians and dances.</li>
</ul>
</li>
</ul>
</li>
</ul>
<h3><strong>Detroit</strong></h3>
<ul>
<li><strong>June 17:</strong> <a href="https://www.eventbrite.com/e/rhythm-art-block-party-tickets-332211703147?aff=ebdssbdestsearch" rel="nofollow">Rhythm and Art Block Party</a>
<ul>
<li>6-10 p.m. at Eastern Market Brewing Company, 2515 Riopelle St.</li>
<li><a href="https://www.eventbrite.com/e/rhythm-art-block-party-tickets-332211703147?aff=ebdssbdestsearch" rel="nofollow">Click here</a> to register.</li>
</ul>
</li>
<li><strong>June 18:</strong> <a href="https://www.facebook.com/events/s/juneteenth-jubilee-stroll-on-l/520514159526865/?_rdc=1&amp;_rdr" rel="nofollow">Juneteenth Jubilee Stroll</a>
<ul>
<li>Noon to 6 p.m. at Livernois Avenue of Fashion</li>
</ul>
</li>
<li><strong>June 18-19:</strong> <a href="https://www.thewright.org/programs/juneteenth-jubilee-freedom-weekend" rel="nofollow">Juneteenth Jubilee Freedom Weekend</a>, The Charles H. Wright Museum of African American History
<ul>
<li><strong>10 a.m. to 4 p.m. June 18:</strong> Underground Railroad Treasure Hunt
<ul>
<li>Participants will explore five sites with significant historical importance in downtown Detroit, including the Gateway to Freedom Sculpture</li>
</ul>
</li>
<li><strong>9 a.m. to 5 p.m. June 19:</strong> Information tables from Community Partners
<ul>
<li>The event focuses on building and extending freedom and equality with the Black community. The museum store will feature unique and classic imagery for Juneteenth.</li>
</ul>
</li>
<li><strong>2 p.m. June 19:</strong> Showcasing of blkfreedom.org presentation &#8220;We the People&#8221;
<ul>
<li>Continued partnership, featuring the Wright Museum along with other African American institutions across the country.</li>
</ul>
</li>
<li><strong>3 p.m. June 19:</strong> Spirits Soar
<ul>
<li>A free concert celebrating genres of music from the days of spirituals to hip hop and electronica.</li>
</ul>
</li>
</ul>
</li>
<li><strong>June 19:</strong> <a href="https://www.eventbrite.com/e/juneteenth-freedom-fest-registration-314859853297" rel="nofollow">Juneteenth Freedom Fest</a>
<ul>
<li>Noon to 6 p.m. at Eastern Market Shed 5, 2810 Russell St., Detroit</li>
<li><a href="https://www.eventbrite.com/e/juneteenth-freedom-fest-registration-314859853297" rel="nofollow">Click here</a> to register. In partnership with the City of Detroit, Detroit Branch NAACP, Juneteenth Jubilee, Charles H. Wright of African American History, Detroit Means Business and the Eastern Market Development Corporation.</li>
</ul>
</li>
</ul>
<h3>Southfield</h3>
<ul>
<li><strong>June 18:</strong> <a href="https://www.cityofsouthfield.com/news/city-southfield-celebrates-juneteenth-week-activities-and-events-june-15-22" rel="nofollow">Mayor&#8217;s Juneteenth Wal</a>k
<ul>
<li>10 a.m. beginning at the Southfield Municipal Campus front circle, a 2.5-mile walk to the Red Pole Park and back to city hall.</li>
</ul>
</li>
<li><strong>June 18:</strong> Southfield Parks &amp; Recreation Juneteenth Celebration
<ul>
<li>Noon to 9 p.m. on the Municipal Campus front lawn.</li>
<li><a href="https://www.cityofsouthfield.com/news/city-southfield-celebrates-juneteenth-week-activities-and-events-june-15-22" rel="nofollow">Click here</a> for more information.</li>
</ul>
</li>
<li><strong>June 19:</strong> Juneteenth Virtual Celebration
<ul>
<li>2-3 p.m., <a href="https://www.eventbrite.com/e/2022-juneteenth-virtual-celebration-tickets-361212284667" rel="nofollow">Click here to register</a></li>
<li>A virtual celebration titled &#8220;Voices of Juneteenth&#8221; focuses on the impact of Juneteenth in the Southfield community.</li>
</ul>
</li>
</ul>
<p><em>&copy; 2022 CBS Broadcasting Inc. All Rights Reserved. This material may not be published, broadcast, rewritten, or redistributed.</em></p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3QBYRxg"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3QBYRxg"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3QBYRxg"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size='[[1,5],"fluid"]' data-ad_location="partner-injected"><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-11"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size='[[300,250],[300,600],[300,1050]]' data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://www.facebook.com/cw50detroit" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/cw50detroit" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
<li><a href="https://cwdetroit.cbslocal.com/2022/06/08/mama-rose-opens-up-her-kitchen-at-the-jamaican-pot-to-the-cw50-crew/" title="Mama Rose Opens Up Her Kitchen at The Jamaican Pot to the CW50 Crew" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/FullSizeRender.jpg?resize=55%2C55&#038;ssl=1" alt="Mama Rose Opens Up Her Kitchen at The Jamaican Pot to the CW50 Crew" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/06/08/mama-rose-opens-up-her-kitchen-at-the-jamaican-pot-to-the-cw50-crew/" title="Mama Rose Opens Up Her Kitchen at The Jamaican Pot to the CW50 Crew" class="bump-view" data-bump-view="tp">Mama Rose Opens Up Her Kitchen at The Jamaican Pot to the CW50 Crew</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/05/06/westland-man-faces-murder-torture-charges-in-wifes-death/" title="Westland Man Faces Murder, Torture Charges In Wife&#039;s Death" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/05/istock_000014316870_small.jpg?resize=55%2C55&#038;ssl=1" alt="Westland Man Faces Murder, Torture Charges In Wife&#039;s Death" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/05/06/westland-man-faces-murder-torture-charges-in-wifes-death/" title="Westland Man Faces Murder, Torture Charges In Wife&#039;s Death" class="bump-view" data-bump-view="tp">Westland Man Faces Murder, Torture Charges In Wife&#039;s Death</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/06/15/artist-jonathan-harris-gives-early-look-at-upcoming-series-shares-thoughts-on-juneteenth/" title="Artist Jonathan Harris Gives Early Look at Upcoming Series, Shares Thoughts on Juneteenth" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/Screen-Shot-2022-06-15-at-10.45.45-AM.jpg?resize=55%2C55&#038;ssl=1" alt="Artist Jonathan Harris Gives Early Look at Upcoming Series, Shares Thoughts on Juneteenth" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/06/15/artist-jonathan-harris-gives-early-look-at-upcoming-series-shares-thoughts-on-juneteenth/" title="Artist Jonathan Harris Gives Early Look at Upcoming Series, Shares Thoughts on Juneteenth" class="bump-view" data-bump-view="tp">Artist Jonathan Harris Gives Early Look at Upcoming Series, Shares Thoughts on Juneteenth</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/06/15/opal-lee-walks-from-texas-to-d-c-in-support-of-juneteenth-her-journey-leads-to-the-creation-of-a-national-holiday/" title="Opal Lee Walks From Texas To D.C. In Support of Juneteenth, Her Journey Leads to the Creation of a National Holiday" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/Screen-Shot-2022-06-15-at-9.43.44-AM.jpg?resize=55%2C55&#038;ssl=1" alt="Opal Lee Walks From Texas To D.C. In Support of Juneteenth, Her Journey Leads to the Creation of a National Holiday" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/06/15/opal-lee-walks-from-texas-to-d-c-in-support-of-juneteenth-her-journey-leads-to-the-creation-of-a-national-holiday/" title="Opal Lee Walks From Texas To D.C. In Support of Juneteenth, Her Journey Leads to the Creation of a National Holiday" class="bump-view" data-bump-view="tp">Opal Lee Walks From Texas To D.C. In Support of Juneteenth, Her Journey Leads to the Creation of a National Holiday</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/06/15/michigan-carpenters-union-opens-new-training-center-in-detroit/" title="Michigan Carpenters Union Opens New Training Center In Detroit" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/CarpenterFramingHouse_748292161.jpg?resize=55%2C55&#038;ssl=1" alt="Michigan Carpenters Union Opens New Training Center In Detroit" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/06/15/michigan-carpenters-union-opens-new-training-center-in-detroit/" title="Michigan Carpenters Union Opens New Training Center In Detroit" class="bump-view" data-bump-view="tp">Michigan Carpenters Union Opens New Training Center In Detroit</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/06/15/police-seek-suspect-who-shot-man-inside-detroit-laundromat/" title="Police Seek Suspect Who Shot Man Inside Detroit Laundromat" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/Untitled-design-26.png?resize=55%2C55&#038;ssl=1" alt="Police Seek Suspect Who Shot Man Inside Detroit Laundromat" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/06/15/police-seek-suspect-who-shot-man-inside-detroit-laundromat/" title="Police Seek Suspect Who Shot Man Inside Detroit Laundromat" class="bump-view" data-bump-view="tp">Police Seek Suspect Who Shot Man Inside Detroit Laundromat</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2022/06/15/jefferson-chalmers-neighborhood-puts-on-jazzin-at-the-vanity-to-revitalize-the-historic-vanity-ballroom/" title="Jefferson-Chalmers Neighborhood Puts on Jazzin&#039; at the Vanity to Revitalize the Historic Vanity Ballroom" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2022/06/IMG_2283.jpg?resize=55%2C55&#038;ssl=1" alt="Jefferson-Chalmers Neighborhood Puts on Jazzin&#039; at the Vanity to Revitalize the Historic Vanity Ballroom" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2022/06/15/jefferson-chalmers-neighborhood-puts-on-jazzin-at-the-vanity-to-revitalize-the-historic-vanity-ballroom/" title="Jefferson-Chalmers Neighborhood Puts on Jazzin&#039; at the Vanity to Revitalize the Historic Vanity Ballroom" class="bump-view" data-bump-view="tp">Jefferson-Chalmers Neighborhood Puts on Jazzin&#039; at the Vanity to Revitalize the Historic Vanity Ballroom</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2020/06/30/amy-smart-dcs-stargirl-the-cw/" title="Amy Smart On &#039;DC&#039;s Stargirl&#039;: &#039;It&#039;s Pure Entertainment&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/06/stargirl11.jpg?resize=55%2C55&#038;ssl=1" alt="Amy Smart On &#039;DC&#039;s Stargirl&#039;: &#039;It&#039;s Pure Entertainment&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/06/30/amy-smart-dcs-stargirl-the-cw/" title="Amy Smart On &#039;DC&#039;s Stargirl&#039;: &#039;It&#039;s Pure Entertainment&#039;" class="bump-view" data-bump-view="tp">Amy Smart On &#039;DC&#039;s Stargirl&#039;: &#039;It&#039;s Pure Entertainment&#039;</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2021/03/03/detroit-zoo-polar-bear-takes-her-first-steps-in-snow-and-it-is-adorable/" title="Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/03/snapshot-25.jpg?resize=55%2C55&#038;ssl=1" alt="Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2021/03/03/detroit-zoo-polar-bear-takes-her-first-steps-in-snow-and-it-is-adorable/" title="Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!" class="bump-view" data-bump-view="tp">Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!</a>
							</div>
							</li><li><a href="https://cwdetroit.cbslocal.com/2020/06/22/penn-jillette-on-looking-forward-to-getting-back-on-stage-post-covid-i-love-doing-shows-its-really-been-my-whole-life/" title="Penn Jillette On Looking Forward To Getting Back On Stage Post-COVID: &#039;I Love Doing Shows, It&#039;s Really Been My Whole Life&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/06/penn-and-teller1.jpg?resize=55%2C55&#038;ssl=1" alt="Penn Jillette On Looking Forward To Getting Back On Stage Post-COVID: &#039;I Love Doing Shows, It&#039;s Really Been My Whole Life&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/06/22/penn-jillette-on-looking-forward-to-getting-back-on-stage-post-covid-i-love-doing-shows-its-really-been-my-whole-life/" title="Penn Jillette On Looking Forward To Getting Back On Stage Post-COVID: &#039;I Love Doing Shows, It&#039;s Really Been My Whole Life&#039;" class="bump-view" data-bump-view="tp">Penn Jillette On Looking Forward To Getting Back On Stage Post-COVID: &#039;I Love Doing Shows, It&#039;s Really Been My Whole Life&#039;</a>
							</div>
							</li></ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size='[[300,250]]' data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size='[[728,90]]' data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://cwdetroit.cbslocal.com" class="logo"><img src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2015/09/cw50_230x86.png" alt="CW50 Detroit" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/cw50detroit" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/cw50detroit" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
	
			<section class="bottom"><div class="wrapper">
			<a href="https://cwdetroit.cbslocal.com" class="logo"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-viacom-logo-white.png" alt="CW50 Detroit" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2022 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=cwdetroit.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
							</div>

			<div class="right-wrapper">
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-262"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-263"><a href="https://www.viacomcbsprivacy.com/policy">Privacy Policy</a></li>
<li id="menu-item-52919" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52919"><a href="https://www.viacomcbsprivacy.com/donotsell">Do Not Sell My Persoanl Information</a></li>
<li id="menu-item-68537" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68537"><a href="https://www.viacomcbsprivacy.com/cookies">Cookies Policy</a></li>
<li id="menu-item-264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264"><a href="http://cwdetroit.cbslocal.com/contact-us/">Contact Us</a></li>
<li id="menu-item-16485" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16485"><a href="http://publicfiles.fcc.gov/tv-profile/WKBD-TV">Public File for WKBD-TV / CW50 Detroit</a></li>
<li id="menu-item-49756" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49756"><a href="http://policies.cbslocal.com/fcc/detroit.television.contact.html">Public File Contact Us for WKBD-TV / CW50 Detroit</a></li>
<li id="menu-item-60381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60381"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-60380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60380"><a href="https://cwdetroit.cbslocal.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-10825" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10825"><a href="http://cbsdetroit.com/eeo">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size='[[1,8]]' data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size='[[1,6]]' data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size='[[1,7]]' data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='screen-css-0' href='https://cwdetroit.cbslocal.com/_static/??-eJzTLy/QTc7PK0nNK9EvyUjNTS3WT04q1s3JT07M0c/MS84pTQEKpeYmpaYAZYqhTN2czOISPSBXR598/brpRZkpFBuSnJ9bkJgMdox9rq2hmamJqbGBibkpAIixT2I=' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1654530475g' type='text/css' media='all' />
<script type="text/javascript" src="https://cwdetroit.cbslocal.com/_static/??-eJx9jEsSgjAMQC9kySDYneNZkEZMTRMmaXW4vYwrV6zfBz5rIJm5JXTIDom8whslqYHhgoI2VbVgTSoV7ApJl/0EB9mOVuXtQcyH+lP15f/GrFJRKpQWVm4Lif9ekznyFoZugHsjTsA6JbS9upVrHy/jOfZxjPkLXyRJ3g==" ></script><script data-parsely-site="cwdetroit.cbslocal.com" src='https://cdn.parsely.com/keys/cwdetroit.cbslocal.com/p.js?ver=3.3.2' id="parsely-cfg"></script>
<script type="text/javascript" src="https://cwdetroit.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1653935630g" ></script><script src='https://w3.mp.lura.live/player/prod/v3/scripts/anvload.js?ver=5.8.4' id='cbs-cbs-anvato-js'></script>
<script src='https://stats.wp.com/e-202224.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9',blog:'162246157',post:'91793',tz:'-4',srv:'cwdetroit.cbslocal.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '162246157', '91793' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>