<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://cwdetroit.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="keywords" content="coronavirus, local, news, ticker, coronavirus, covid-19, cumulative data, michigan" />
<meta property="fb:pages" content="245397755489628" />
<title>Michigan Reports 614 New COVID-19 Cases, 24 Deaths &#8211; CW50 Detroit</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="CW50 Detroit &raquo; Feed" href="https://cwdetroit.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://cwdetroit.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsFpEYYM4Sz6mRHXsKB9xfULKhhVUYmV77DcawyMqK1yQC5Q7BsxgTVYkVhN4tlTdS8oZbiIF0761O/gJwmDQrWxMSKLddzhSnT1nCOIqtY1+G7S6He4HKmjWM6Zu86GoFnIpEje8tHrUYFh7UuR5+X8qpDZx6f9ew2WYhtN5PB7G6Ql1k59a' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://cwdetroit.cbslocal.com/_static/??-eJytU9FOwzAM/CGybGMa8ID4ljS1ujAnjmJ3Vf+epHRUY8DaiTc79p191kV3UVkKAkG0HMADa1uxQrIGNUuPsLLMD/qvNhcstnV5YtbRNKAEfEQjM7AFApgfg/Dt7oht4wJrT3WLuTI0KG9CHpoGLukj7Bau3Ll6WnnGFt/0pns25wMlsXRmmdIF48FXUH/ih1ChY1HWiEFqFsrIKpxFUKfpeBf1OlPrKgOPeUqVTOpHd3gXlqvPF29Avq5f4isS36oz7B0kmjz5ZfV0RSEUVSTO0Uy33vaQN+lYqEeHElL6F29e8tIJUpfcD5/kF+WFYswL5M2/bvbb9fN+t37cfgCzFmp/' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://cwdetroit.cbslocal.com/_static/??-eJy1UEEOwjAM+xClY0MTF8RbSpeNljQtSwra7ykTB3YbSJysOLZjRT+SspEESLRcIABre2aF0RrUjizmrlCedYo49Q5xGxxtPW/0WqNf5UiYB0esQ+wylo3pZnMBda8/ExbRtwzj9IZVIhXcMBqBnzrNAhUMmQHGV/SCUOXeVWL66jl9JisuEv+jEGCZSLjknsJx19bVod1XTeOfsLy6Mw=='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7.2' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://cwdetroit.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILephMA6Ib+naqEuVphNJ2e+vQly4sJtlP9uwb0OoYigGtmJBhbDowDV4BpLALXYrK/i4otIbx0IyZr3Av2LnE9fF8yn5c/EyCoynnY1bIlEoNTbuyU4xoX0mvrJPPMvDTffrdJudm/MBCxBU3Q=='></script>
<link rel="https://api.w.org/" href="https://cwdetroit.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://cwdetroit.cbslocal.com/wp-json/wp/v2/posts/65756" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cwdetroit.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cwdetroit.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://cbsloc.al/3upWxwU' />
<link rel="alternate" type="application/json+oembed" href="https://cwdetroit.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcwdetroit.cbslocal.com%2F2021%2F05%2F28%2Fmichigan-reports-614-new-covid-19-cases-24-deaths%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://cwdetroit.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcwdetroit.cbslocal.com%2F2021%2F05%2F28%2Fmichigan-reports-614-new-covid-19-cases-24-deaths%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<meta property="og:title" content="Michigan Reports 614 New COVID-19 Cases, 24 Deaths" /><meta property="og:image" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/shutterstock_1624635628-3.jpg?w=1500" /><meta property="og:image:secure_url" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/shutterstock_1624635628-3.jpg?w=1500" /><meta property="og:image:width" content="1500" /><meta property="og:image:height" content="844" /><meta property="og:description" content="The Michigan Department of Health and Human Services announced new coronavirus cases and additional deaths in the state. Here&#039;s everything to know." /><meta property="og:type" content="article" /><meta property="og:url" content="https://cwdetroit.cbslocal.com/2021/05/28/michigan-reports-614-new-covid-19-cases-24-deaths/" /><meta property="article:published_time" content="2021-05-28T15:07:12+00:00" /><meta property="article:suggested-social-copy" content="The Michigan Department of Health and Human Services announced new coronavirus cases and additional deaths in the state. Here&#039;s everything to know." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Coronavirus,Local,News,Ticker" /><meta property="article:publisher" content="http://www.facebook.com/cw50detroit" /><meta property="article:author" content="http://www.facebook.com/cw50detroit" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/shutterstock_1624635628-3.jpg?w=1500"><meta name="twitter:title" content="Michigan Reports 614 New COVID-19 Cases, 24 Deaths"/><meta name="twitter:description" content="The Michigan Department of Health and Human Services announced new coronavirus cases and additional deaths in the state. Here&#039;s everything to know."/><meta name="twitter:site" content="/cw50detroit"/>
<link rel="canonical" href="https://cwdetroit.cbslocal.com/2021/05/28/michigan-reports-614-new-covid-19-cases-24-deaths/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://cwdetroit.cbslocal.com/2021/05/28/michigan-reports-614-new-covid-19-cases-24-deaths/?amp">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/cwdetroit.cbslocal.com","url":"https:\/\/cwdetroit.cbslocal.com","name":"CW50 Detroit","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/cwdetroit.cbslocal.com\/wp-content\/uploads\/sites\/31326028\/2018\/07\/4_detroit_cw50.png?w=158"}},"url":"https:\/\/cwdetroit.cbslocal.com\/2021\/05\/28\/michigan-reports-614-new-covid-19-cases-24-deaths\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/cwdetroit.cbslocal.com\/2021\/05\/28\/michigan-reports-614-new-covid-19-cases-24-deaths\/"},"headline":"Michigan Reports 614 New COVID-19 Cases, 24 Deaths","description":"The Michigan Department of Health and Human Services announced new coronavirus cases and additional deaths in the state. Here's everything to know.","image":"https:\/\/cwdetroit.cbslocal.com\/wp-content\/uploads\/sites\/31326028\/2021\/05\/shutterstock_1624635628-3.jpg?w=1500","keywords":["Coronavirus","Local","News","Ticker","coronavirus","covid-19","cumulative data","Michigan","news","Michigan Reports 614 New COVID-19 Cases, 24 Deaths"],"datePublished":"2021-05-28T15:07:12+00:00","dateModified":"2021-05-28T15:07:12+00:00","author":{"@type":"Organization","name":"CW50 Detroit"},"video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"'Monroe Street Midway' Featuring Roller Rink, Basketball, Art, Food, Opens Friday In Downtown Detroit","description":"The Monroe street Midway formally Monroe street drive-in opens Friday May 28. Will feature Detroits only outdoor roller rink, art, food, sports zones. Runs through the fall.","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/anv-iupl\/8FC\/7DB\/8FC7DBC4B65D4679BD0D1612C228AEF3.jpg?Expires=1716854400&KeyName=mcpkey1&Signature=lyu8fN-cvO2DhBgnpdtWvjRXcsA","uploadDate":"2021-05-28","duration":"T1M45S","contentUrl":"https:\/\/cwdetroit.cbslocal.com\/video\/5630237-monroe-street-midway-featuring-roller-rink-basketball-art-food-opens-friday-in-downtown-detroit\/","embedUrl":"https:\/\/cwdetroit.cbslocal.com\/video\/5630237-monroe-street-midway-featuring-roller-rink-basketball-art-food-opens-friday-in-downtown-detroit\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script>
<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CW.DET","news",["michiganreports614newcovid19cases24deaths","post","article","coronavirus","local","news","ticker","covid19","cumulativedata","michigan","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("2");</script>
<!-- WP Header - End -->

	<meta name="description" content="The Michigan Department of Health and Human Services announced new coronavirus cases and additional deaths in the state. Here&#039;s everything to know." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-65756 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://cwdetroit.cbslocal.com" id="header-logo"><img src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2018/07/4_detroit_cw50.png?w=158" alt="CW50 Detroit" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Latest Update</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/2021/05/28/michigan-reports-614-new-covid-19-cases-24-deaths/" title="Michigan Reports 614 New COVID-19 Cases, 24 Deaths" class="cbs-thumbnail-link item-1622228832" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/shutterstock_1624635628-3.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Michigan Reports 614 New COVID-19 Cases, 24 Deaths</strong><em class="description">The Michigan Department of Health and Human Services announced new coronavirus cases and additional deaths in the state. Here&#039;s everything to know.</em></div></a><a href="https://cwdetroit.cbslocal.com/2021/05/28/police-suspect-wanted-in-carjacking-on-detroits-west-side/" title="Police: Suspect Wanted In Carjacking On Detroit&#039;s West Side" class="cbs-thumbnail-link item-1622227193" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/Screen-Shot-2021-05-28-at-2.39.23-PM.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Police: Suspect Wanted In Carjacking On Detroit&#039;s West Side</strong><em class="description">Detroit Police are seeking to locate a suspect wanted in connection to a carjacking that occurred on the city’s west side.</em></div></a><a href="https://cwdetroit.cbslocal.com/2021/05/28/enrollment-open-for-young-children-in-moderna-vaccine-study-2/" title="Enrollment Open For Young Children In Moderna Vaccine Study" class="cbs-thumbnail-link item-1622226074" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/GettyImages-1266808661-4.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Enrollment Open For Young Children In Moderna Vaccine Study</strong><em class="description">A Detroit-based health system is enrolling children ages 6 months to 11 years old for Moderna’s COVID-19 vaccine study.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Eye on Detroit</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/2021/05/27/seedlings-braille-books-for-children-increasing-the-opportunity-for-literacy/" title="Seedlings Braille Books For Children, Increasing The Opportunity For Literacy" class="cbs-thumbnail-link item-1622169001 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/02/seeds.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Seedlings Braille Books For Children, Increasing The Opportunity For Literacy</strong><em class="description">&quot;If We Didn&#039;t Have These Books From Seedlings, Then None Of Us Would Be Able To Read. Imagine that!&quot;</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Coming Up</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/2021/05/22/o-the-tangled-web-charmed-2/" title="O, The Tangled Web - Charmed" class="cbs-thumbnail-link item-1621656094" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/03/CMD308b_0032r.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">O, The Tangled Web - Charmed</strong><em class="description">Macy reels from an encounter with the Shea Group and Maggie uses her psych background to get to the bottom of it.</em></div></a><a href="https://cwdetroit.cbslocal.com/2021/05/22/everybody-loves-the-carringtons-dynasty/" title="Everybody Loves The Carringtons - Dynasty" class="cbs-thumbnail-link item-1621656011" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/DYN404a_0088rbw.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Everybody Loves The Carringtons - Dynasty</strong><em class="description">Jeff and Alexis create havoc during Fallon and Liam’s important interview which spurs a “brilliant idea” for Fallon. </em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://cwdetroit.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
	
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/2021/05/28/michigan-reports-614-new-covid-19-cases-24-deaths/" title="Michigan Reports 614 New COVID-19 Cases, 24 Deaths" class="cbs-thumbnail-link item-1622228832" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/shutterstock_1624635628-3.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Michigan Reports 614 New COVID-19 Cases, 24 Deaths</strong><em class="description">The Michigan Department of Health and Human Services announced new coronavirus cases and additional deaths in the state. Here&#039;s everything to know.</em></div></a><a href="https://cwdetroit.cbslocal.com/2021/05/28/police-suspect-wanted-in-carjacking-on-detroits-west-side/" title="Police: Suspect Wanted In Carjacking On Detroit&#039;s West Side" class="cbs-thumbnail-link item-1622227193" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/Screen-Shot-2021-05-28-at-2.39.23-PM.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Police: Suspect Wanted In Carjacking On Detroit&#039;s West Side</strong><em class="description">Detroit Police are seeking to locate a suspect wanted in connection to a carjacking that occurred on the city’s west side.</em></div></a><a href="https://cwdetroit.cbslocal.com/2021/05/28/enrollment-open-for-young-children-in-moderna-vaccine-study-2/" title="Enrollment Open For Young Children In Moderna Vaccine Study" class="cbs-thumbnail-link item-1622226074" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/GettyImages-1266808661-4.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Enrollment Open For Young Children In Moderna Vaccine Study</strong><em class="description">A Detroit-based health system is enrolling children ages 6 months to 11 years old for Moderna’s COVID-19 vaccine study.</em></div></a><a href="https://cwdetroit.cbslocal.com/2021/05/28/michigan-health-department-recommends-avoiding-foam-on-lakes-and-rivers/" title="Michigan Health Department Recommends Avoiding Foam On Lakes And Rivers" class="cbs-thumbnail-link item-1622223444 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/banner_original.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Michigan Health Department Recommends Avoiding Foam On Lakes And Rivers</strong><em class="description">As the summer months approach, the Michigan Department of Health and Human Services is issuing its annual recommendation that Michiganders should avoid contact with foam they may see on Michigan water bodies such as lakes, rivers and streams.</em></div></a><a href="https://cwdetroit.cbslocal.com/2021/05/28/metro-detroit-engineer-featured-on-cbs-mission-unstoppable-for-ground-breaking-gm-technology/" title="Metro Detroit Engineer Featured On CBS &#039;Mission Unstoppable&#039; For Ground Breaking GM Technology" class="cbs-thumbnail-link item-1622222292" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/image-19.png?w=310&#038;h=157&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Metro Detroit Engineer Featured On CBS &#039;Mission Unstoppable&#039; For Ground Breaking GM Technology</strong><em class="description">30 year veteran engineer from metro Detroit is featured on a National CBS show for her role in groundbreaking technology in the 2021 Cadillac Escalade</em></div></a><a href="https://cwdetroit.cbslocal.com/2021/05/28/police-investigating-deadly-shootings-in-detroit/" title="Police Investigating Deadly Shootings In Detroit" class="cbs-thumbnail-link item-1622211232" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/shutterstock_1191163906-10.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Police Investigating Deadly Shootings In Detroit</strong><em class="description">Police are investigating deadly shootings that happened Thursday in Detroit.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link"><a href="http://cwdetroit.cbslocal.com/cw-detroit-tv-schedule" title="TV Schedule" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">TV Schedule</strong></div></a></li><li class="menu-top-item item-3 w-link"><a href="http://cwdetroit.cbslocal.com/tag/cw50-street-team/" title="Street Team" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Street Team</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://cwdetroit.cbslocal.com/category/detroit-proud/" title="Detroit Proud" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Detroit Proud</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
	
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/2020/02/24/detroit-proud-playlist-hamtramck-music-festival/" title="Detroit Proud Playlist: Hamtramck Music Festival" class="cbs-thumbnail-link item-1582565278" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Hamtramck Music Festival</strong><em class="description">The City of Hamtramck comes alive with art, culture, and music via the Hamtramck Music Festival, featuring 200 bands playing 24 venues and restaurants.</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/09/04/detroit-proud-playlist-dally-in-the-alley/" title="Detroit Proud Playlist: Dally In The Alley" class="cbs-thumbnail-link item-1567614651" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Dally In The Alley</strong><em class="description">Dally in the Alley is the go-to event of the summer to discover your new favorite local headliner or underground group. Get into the spirit with this week&#039;s Playlist!</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/07/16/detroit-proud-playlist-pig-whiskey-2019/" title="Detroit Proud Playlist: Pig &amp; Whiskey 2019" class="cbs-thumbnail-link item-1563305958" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Pig &amp; Whiskey 2019</strong><em class="description">Pig &amp; Whiskey Festival encapsulates a Michigan summer in one weekend. We’ve curated a schedule with an eclectic mix of bands that pairs well with any kind of BBQ, brew, or whiskey that you choose to enjoy alongside the music.</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/03/04/detroit-proud-playlist-hamtramck-music-festival-2019/" title="Detroit Proud Playlist: Hamtramck Music Festival 2019!" class="cbs-thumbnail-link item-1551716768" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Hamtramck Music Festival 2019!</strong><em class="description">It&#039;s that time of year again! We’ve selected an eclectic mix of can’t-miss bands playing this weekend&#039;s Hamtramck Music Festival for this week&#039;s Detroit Proud Playlist!</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/02/18/detroit-proud-playlist-guest-dj-vazum-frontman-zach-pliska/" title="Detroit Proud Playlist: Guest DJ - VAZUM Frontman Zach Pliska!" class="cbs-thumbnail-link item-1550466084" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2013/08/dpplaylistimage2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Guest DJ - VAZUM Frontman Zach Pliska!</strong><em class="description">This week, we have a special Guest DJ-ed playlist, curated by VAZUM frontman Zach Pliska! Zach put his own spin on our Detroit Proud Playlist this week - check out his picks below!</em></div></a><a href="https://cwdetroit.cbslocal.com/2018/12/03/detroit-proud-playlist-week-of-12-3/" title="Detroit Proud Playlist: Week of 12/3" class="cbs-thumbnail-link item-1543848574" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2013/07/dpplaylistimage2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Week of 12/3</strong><em class="description">The playlist is here for another week of Detroit music! We have new tunes, old tunes, and a little something for everyone. Check it out!</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://cwdetroit.cbslocal.com/video/category/spoken-word-wkbdtv/">News</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/video/5632970-police-suspect-wanted-in-carjacking-on-detroits-west-side/" title="Police: Suspect Wanted In Carjacking On Detroit&#039;s West Side" class="cbs-thumbnail-link item-1622226960 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-pvw/E06/F85/E06F85A695E74D9CB30F1E16CCF0E048_2.jpg?Expires=1716854400&#038;KeyName=mcpkey1&#038;Signature=gxRF9RYiB-n78I1KzdqqejI_2Ss"></span></div><div class="title-wrapper"><strong class="title">Police: Suspect Wanted In Carjacking On Detroit&#039;s West Side</strong><em class="description">Police: Suspect Wanted In Carjacking On Detroit&#039;s West Side</em></div><time datetime="2021-05-28T18:36:00+00:00" title="May 28, 2021 at 2:36 pm">3 hours ago</time></a><a href="https://cwdetroit.cbslocal.com/video/5627599-eye-on-detroit-michigan-veterans-affairs-agency/" title="Eye On Detroit - Michigan Veterans Affairs Agency" class="cbs-thumbnail-link item-1622203200 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-pvw/8BE/5FA/8BE5FA409AC94429A7963A74F1AA7ACD_3.jpg?Expires=1716854400&#038;KeyName=mcpkey1&#038;Signature=3-pEykDC1XdOef_wpf3aBkSNLDc"></span></div><div class="title-wrapper"><strong class="title">Eye On Detroit - Michigan Veterans Affairs Agency</strong><em class="description">In the second of several planned COVID-19 veteran vaccination clinics around Michigan, the Department of Military and Veterans Affairs (DMVA) vaccinated veterans, their spouses, family members and caregivers on April 26 at the Lakeside Mall Drive-Thru in Sterling Heights. All vaccine recipients must be 18 or older.</em></div><time datetime="2021-05-28T12:00:00+00:00" title="May 28, 2021 at 8:00 am">9 hours ago</time></a><a href="https://cwdetroit.cbslocal.com/video/5627659-eye-on-detroit-sass/" title="Eye On Detroit - SASS" class="cbs-thumbnail-link item-1622124420 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-pvw/974/273/974273EDE2F54AA394833F53C65CC7F0_1.jpg?Expires=1716854400&#038;KeyName=mcpkey1&#038;Signature=5FCPA3Htquf8tLDt8q0MxTcrDqI"></span></div><div class="title-wrapper"><strong class="title">Eye On Detroit - SASS</strong><em class="description">The mission at SAAS is to bring Hope,Help, and Healing to victims of domestic violence and sexual assault within the black and African American community without regards to gender, sexual orientation, religious or faith affiliation (or none at all), economic status, or culture.</em></div><time datetime="2021-05-27T14:07:00+00:00" title="May 27, 2021 at 10:07 am">1 day ago</time></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Community Affairs</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/video/5610549-community-connect-segments-cindy-eggleton/" title="Community Connect Segments - Cindy Eggleton" class="cbs-thumbnail-link item-1621769400 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/2AF/70D/2AF70D1785BA4AFDA46583F2A2E1D734.jpg?Expires=1716854400&#038;KeyName=mcpkey1&#038;Signature=1-ZiBP-fM32Z92pJCnbX29GlBwY"></span></div><div class="title-wrapper"><strong class="title">Community Connect Segments - Cindy Eggleton</strong><em class="description">On this week&#039;s Community Connect, we learn the real cholinic issues leading to poverty in the city of Detroit from the people who are helping to change the narrative and break the cycle.</em></div><time datetime="2021-05-23T11:30:00+00:00" title="May 23, 2021 at 7:30 am">5 days ago</time></a><a href="https://cwdetroit.cbslocal.com/video/5587790-community-connect-breaking-the-cycle/" title="Community Connect: Breaking the Cycle" class="cbs-thumbnail-link item-1621683000 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/E0A/163/E0A163D6253F4792835A8BD59381E0A2.jpg?Expires=1716854400&#038;KeyName=mcpkey1&#038;Signature=XrVdrzdBKzQlQXTB0loy8r_uCYE"></span></div><div class="title-wrapper"><strong class="title">Community Connect: Breaking the Cycle</strong><em class="description">On this week&#039;s Community Connect, we learn the real cholinic issues leading to poverty in the city of Detroit from the people who are helping to change the narrative and break the cycle.</em></div><time datetime="2021-05-22T11:30:00+00:00" title="May 22, 2021 at 7:30 am">6 days ago</time></a><a href="https://cwdetroit.cbslocal.com/video/5564952-community-connect-financial-literacy/" title="Community Connect: Financial Literacy" class="cbs-thumbnail-link item-1621078200 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/FC4/E92/FC4E924CC55240D887BD690296BE55B0.jpg?Expires=1716854400&#038;KeyName=mcpkey1&#038;Signature=mWEqaKFuCYB1hLsotYBC1CUEZg8"></span></div><div class="title-wrapper"><strong class="title">Community Connect: Financial Literacy</strong><em class="description">On this week&#039;s Community Connect, from dollars to cents – we get insight into financial literacy and cryptocurrencies of the future.</em></div><time datetime="2021-05-15T11:30:00+00:00" title="May 15, 2021 at 7:30 am">13 days ago</time></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-link"><a href="http://detroit.cbslocal.com/" title="CBS Detroit" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CBS Detroit</strong></div></a></li></ul></nav>
	<ul id="live"><li class="menu-item item-0"><a href="/live/channel/wwj-tv/" title="WWJ-TV" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">WWJ-TV</strong><em class="description">On Air</em></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">5:00 PM</strong><em class="description">Dr. Phil</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">6:00 PM</strong><em class="description">Family Feud</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">6:30 PM</strong><em class="description">CBS Evening News with Norah O'Donnell</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">7:00 PM</strong><em class="description">Family Feud</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">7:30 PM</strong><em class="description">Family Feud</em></div></div></div>
</div></div><a class="view-all" href="https://cwdetroit.cbslocal.com/program-guide/">View All Programs</a></div></div></li></ul>
	
	<div id="info-search"><form action="https://cwdetroit.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size='[[970,250],[970,66],[728,90]]' data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">Michigan Reports 614 New COVID-19 Cases, 24 Deaths</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">May 28, 2021 at 3:07 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://cwdetroit.cbslocal.com/tag/coronavirus/">coronavirus</a>, <a href="https://cwdetroit.cbslocal.com/tag/covid-19/">covid-19</a>, <a href="https://cwdetroit.cbslocal.com/tag/cumulative-data/">cumulative data</a>, <a href="https://cwdetroit.cbslocal.com/tag/michigan/">Michigan</a></div></div></section><section id="column_block_2" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato-program  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"5630237","autoplay":true,"titleVisible":false,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5"},"comscore":{"clientId":"3000023","c3":"cwdetroit.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/cw.det&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/cbsloc.al\/3upWxwU","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5,"recom":true,"maxRecomPages":3});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>MICHIGAN (CBS DETROIT)</strong> &#8211; The Michigan Department of Health and Human Services announced <strong>614 coronavirus cases in the state and an additional 24 deaths Friday.</strong></p>
<p>This brings the state total of COVID-19 cases to <strong>887,274 and 19,114</strong>&nbsp;<strong>deaths as of May 28.</strong></p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://cwdetroit.cbslocal.com/2021/05/28/police-suspect-wanted-in-carjacking-on-detroits-west-side/" target="_blank">Police: Suspect Wanted In Carjacking On Detroit&#039;s West Side</a>
<p>The health department says data will not be updated Monday, May 31, due to the state holiday. Data will resume posting on Tuesday, June 1.</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://cwdetroit.cbslocal.com/2021/05/28/enrollment-open-for-young-children-in-moderna-vaccine-study-2/" target="_blank">Enrollment Open For Young Children In Moderna Vaccine Study</a>
<p><img class="aligncenter wp-image-1062341 size-full" src="https://detroit.cbslocal.com/wp-content/uploads/sites/15909782/2021/05/Screen-Shot-2021-05-28-at-3.00.19-PM.png" alt="" width="625"></p>
<p>In the state, as of May 21, there has been a total of <strong>791,206 </strong>recovered cases of COVID-19.</p><strong style="color: black; float: left; padding-right: 5px;">MORE NEWS: </strong><a style="display: block; margin-bottom: 25px;" href="https://cwdetroit.cbslocal.com/2021/05/28/michigan-health-department-recommends-avoiding-foam-on-lakes-and-rivers/" target="_blank">Michigan Health Department Recommends Avoiding Foam On Lakes And Rivers</a>
<p>For the latest numbers, visit <a href="https://www.michigan.gov/coronavirus/0,9753,7-406-98163-520743--,00.html" rel="nofollow">here</a>. They are updated daily with coronavirus updates included as of 3 p.m.</p>
<div>
<div><em>&copy; 2021 CBS Broadcasting Inc. All Rights Reserved. This material may not be published, broadcast, rewritten, or redistributed.</em></div>
</div>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3upWxwU"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3upWxwU"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3upWxwU"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size='[[1,5],"fluid"]' data-ad_location="partner-injected"><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-3"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size='[[300,250],[300,600],[300,1050]]' data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://www.facebook.com/cw50detroit" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/cw50detroit" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://cwdetroit.cbslocal.com/2021/05/26/fly-away-to-the-past-at-selfridge-military-air-museum/" title="Fly Away To The Past At Selfridge Military Air Museum" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/Selfridge.jpg?resize=55%2C55&#038;ssl=1" alt="Fly Away To The Past At Selfridge Military Air Museum" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2021/05/26/fly-away-to-the-past-at-selfridge-military-air-museum/" title="Fly Away To The Past At Selfridge Military Air Museum" class="bump-view" data-bump-view="tp">Fly Away To The Past At Selfridge Military Air Museum</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2015/04/28/big-cat-rescue-tests-if-lions-and-tigers-chase-laser-pointers-just-like-a-housecat/" title="Big Cat Rescue Tests If Lions And Tigers Chase Laser Pointers Just Like A Housecat" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2015/04/istock_000031888044_large.jpg?resize=55%2C55&#038;ssl=1" alt="Big Cat Rescue Tests If Lions And Tigers Chase Laser Pointers Just Like A Housecat" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2015/04/28/big-cat-rescue-tests-if-lions-and-tigers-chase-laser-pointers-just-like-a-housecat/" title="Big Cat Rescue Tests If Lions And Tigers Chase Laser Pointers Just Like A Housecat" class="bump-view" data-bump-view="tp">Big Cat Rescue Tests If Lions And Tigers Chase Laser Pointers Just Like A Housecat</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2021/05/25/michigan-war-dog-memorial-honors-the-fallen-dogs-who-served-alongside-u-s-soldiers/" title="Michigan War Dog Memorial Honors The Fallen Dogs Who Served Alongside U.S. Soldiers" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/War-Dog-Memorial.jpg?resize=55%2C55&#038;ssl=1" alt="Michigan War Dog Memorial Honors The Fallen Dogs Who Served Alongside U.S. Soldiers" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2021/05/25/michigan-war-dog-memorial-honors-the-fallen-dogs-who-served-alongside-u-s-soldiers/" title="Michigan War Dog Memorial Honors The Fallen Dogs Who Served Alongside U.S. Soldiers" class="bump-view" data-bump-view="tp">Michigan War Dog Memorial Honors The Fallen Dogs Who Served Alongside U.S. Soldiers</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2014/05/01/my-diy-solution-for-cats-treating-my-kids-sandbox-like-a-litterbox/" title="DIY Cover Stops Cats From Treating My Kid&#039;s Sandbox Like A Litterbox" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2014/05/img_20140427_113956_447.jpg?resize=55%2C55&#038;ssl=1" alt="DIY Cover Stops Cats From Treating My Kid&#039;s Sandbox Like A Litterbox" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2014/05/01/my-diy-solution-for-cats-treating-my-kids-sandbox-like-a-litterbox/" title="DIY Cover Stops Cats From Treating My Kid&#039;s Sandbox Like A Litterbox" class="bump-view" data-bump-view="tp">DIY Cover Stops Cats From Treating My Kid&#039;s Sandbox Like A Litterbox</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2021/05/27/west-virginia-prosecutors-charge-9-people-from-detroit-with-drug-trafficking/" title="West Virginia Prosecutors Charge 9 People From Detroit With Drug Trafficking" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/v-1.jpg?resize=55%2C55&#038;ssl=1" alt="West Virginia Prosecutors Charge 9 People From Detroit With Drug Trafficking" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2021/05/27/west-virginia-prosecutors-charge-9-people-from-detroit-with-drug-trafficking/" title="West Virginia Prosecutors Charge 9 People From Detroit With Drug Trafficking" class="bump-view" data-bump-view="tp">West Virginia Prosecutors Charge 9 People From Detroit With Drug Trafficking</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2021/05/24/missed-gov-whitmers-press-conference-heres-her-update-on-the-states-response-to-covid-19/" title="Missed Gov. Whitmer&#039;s Press Conference? Here&#039;s Her Update On The State&#039;s Response To COVID-19" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/Screen-Shot-2021-05-24-at-11.34.48-AM.png?resize=55%2C55&#038;ssl=1" alt="Missed Gov. Whitmer&#039;s Press Conference? Here&#039;s Her Update On The State&#039;s Response To COVID-19" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2021/05/24/missed-gov-whitmers-press-conference-heres-her-update-on-the-states-response-to-covid-19/" title="Missed Gov. Whitmer&#039;s Press Conference? Here&#039;s Her Update On The State&#039;s Response To COVID-19" class="bump-view" data-bump-view="tp">Missed Gov. Whitmer&#039;s Press Conference? Here&#039;s Her Update On The State&#039;s Response To COVID-19</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2021/05/27/governor-whitmer-visits-i-75-m-46-construction-project-in-saginaw/" title="Governor Whitmer Visits I-75/M-46 Construction Project In Saginaw" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/govconstruction052721-11-of-12-1_original.jpg?resize=55%2C55&#038;ssl=1" alt="Governor Whitmer Visits I-75/M-46 Construction Project In Saginaw" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2021/05/27/governor-whitmer-visits-i-75-m-46-construction-project-in-saginaw/" title="Governor Whitmer Visits I-75/M-46 Construction Project In Saginaw" class="bump-view" data-bump-view="tp">Governor Whitmer Visits I-75/M-46 Construction Project In Saginaw</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2021/05/04/what-is-cinco-de-mayo/" title="What is Cinco de Mayo?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/GettyImages-1221326708.jpg?resize=55%2C55&#038;ssl=1" alt="What is Cinco de Mayo?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2021/05/04/what-is-cinco-de-mayo/" title="What is Cinco de Mayo?" class="bump-view" data-bump-view="tp">What is Cinco de Mayo?</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2021/03/03/detroit-zoo-polar-bear-takes-her-first-steps-in-snow-and-it-is-adorable/" title="Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/03/snapshot-25.jpg?resize=55%2C55&#038;ssl=1" alt="Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2021/03/03/detroit-zoo-polar-bear-takes-her-first-steps-in-snow-and-it-is-adorable/" title="Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!" class="bump-view" data-bump-view="tp">Detroit Zoo Polar Bear Takes Her First Steps In Snow and it is Adorable!</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2021/05/27/police-27-year-old-man-critical-after-detroit-stabbing/" title="Police: 27-Year-Old Man Critical After Detroit Stabbing" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2021/05/shutterstock_1191163906-9.jpg?resize=55%2C55&#038;ssl=1" alt="Police: 27-Year-Old Man Critical After Detroit Stabbing" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2021/05/27/police-27-year-old-man-critical-after-detroit-stabbing/" title="Police: 27-Year-Old Man Critical After Detroit Stabbing" class="bump-view" data-bump-view="tp">Police: 27-Year-Old Man Critical After Detroit Stabbing</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size='[[300,250]]' data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size='[[728,90]]' data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://cwdetroit.cbslocal.com" class="logo"><img src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2015/09/cw50_230x86.png" alt="CW50 Detroit" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/cw50detroit" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/cw50detroit" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
	
			<section class="bottom"><div class="wrapper">
			<a href="https://cwdetroit.cbslocal.com" class="logo"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-viacom-logo-white.png" alt="CW50 Detroit" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=cwdetroit.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-263"><a href="http://policies.cbslocal.com/privacy/current.html">Privacy Policy</a></li>
<li id="menu-item-262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-262"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-52918" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52918"><a href="https://ca.privacy.cbs/">California Privacy/Info We Collect</a></li>
<li id="menu-item-52919" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52919"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Persoanl Information</a></li>
<li id="menu-item-36241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36241"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-36242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36242"><a href="https://privacy.cbs/personalizedads">Ad Choices</a></li>
<li id="menu-item-264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264"><a href="http://cwdetroit.cbslocal.com/contact-us/">Contact Us</a></li>
<li id="menu-item-16485" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16485"><a href="http://publicfiles.fcc.gov/tv-profile/wkbd-tv">Public File for WKBD-TV / CW50 Detroit</a></li>
<li id="menu-item-49756" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49756"><a href="http://policies.cbslocal.com/fcc/detroit.television.contact.html">Public File Contact Us for WKBD-TV / CW50 Detroit</a></li>
<li id="menu-item-60381" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60381"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-60380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60380"><a href="https://cwdetroit.cbslocal.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-10825" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10825"><a href="http://cbsdetroit.com/eeo">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size='[[1,8]]' data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size='[[1,6]]' data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size='[[1,7]]' data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='screen-css-0' href='https://cwdetroit.cbslocal.com/_static/??-eJzTLy/QTc7PK0nNK9EvyUjNTS3WT04q1s3JT07M0c/MS84pTQEKpeYmpaYAZYqhTN2czOISPSBXR598/UB9uQWJyWBz7HNtDU0tzUzNLQwNLQAadjWz' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1596578118g' type='text/css' media='all' />
<script type='text/javascript' src='https://cwdetroit.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1620864034g'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7.2' id='cbs-cbs-anvato-js'></script>
<script src='https://stats.wp.com/e-202121.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.7',blog:'162246157',post:'65756',tz:'-4',srv:'cwdetroit.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246157', '65756' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>