<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" /><script type="text/javascript">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</script>
	<link rel="pingback" href="https://cwdetroit.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="keywords" content="local, news, ticker, uncategorized, bria brown, cryss walker, execution-style killings, isis rimson, nicholas raad bahri, tai&#039;raz moore, tukoyo moore, warren, warren police" />
<meta property="fb:pages" content="245397755489628" />
<title>West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others &#8211; CW50 Detroit</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="CW50 Detroit &raquo; Feed" href="https://cwdetroit.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CW50 Detroit &raquo; Comments Feed" href="https://cwdetroit.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CW50 Detroit &raquo; West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others Comments Feed" href="https://cwdetroit.cbslocal.com/2020/10/13/west-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://cwdetroit.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsCJAggXiLPmYEtWxo3zU6xNSNqygEivbY7/RGJaknHBFrlAfGLGAs0WROEMQ2FHzL6kUuItUzPve7uAnCKNFv7IpI4nx3+FEbQpcIIpv1DfmbdDrdngcqGjYTJiHzYeiesi5Strw0urRomUTSFHg+f+pkPrEdfx7i1d9umitj+eDfgJ1eZ9T' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://cwdetroit.cbslocal.com/_static/??-eJytU9FOwzAM/CGybGgb8ID4ljS1ujAnjmJ3Vf+epHSrxoC1iDc79p191kV3UVkKAkG0HMADa1uxQrIGNUuPsLLMD/q3NhcstnV5YtbRNKAEfEQjM7AFApgfg/D97oht4wJrT3WLuTI0KG9CHpoGLukjbBeu3Ll6WnnGFl/0pr9szgdKYunMMqULxoOvoP7ED6FCx6KsEYPULJSRVTiLoE7T8a7qdabWVQYe85QqmdSP7vAuLFefL96AXK5f4hsS36oz7B0kmjz5ZbW+oRCKKhLnaKZb73vIm3Qs1KNDCSn9izeveekEqUvum0/yg/JCMeYF8uZfN/v1Zvf8uHvafgCqnGp4' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://cwdetroit.cbslocal.com/_static/??-eJydT0ESwiAM/JA06ujYHhzfQoFWMARsQKe/Fzse7MnW00422d0sPKNQgZKhBOlqvGFQLQsMSiJYUph1oRxDDDh2FrHylirHG1gqdIsUEXNvicEHnbFspJ7EBcRj/+0ws75nM4wfWB0xHQgvSfZmeNvNCFEybinEVV27TCrZQPxX5x8PGSwTJS6+F3/eHZu6qU+Hbe1efZan2A=='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.5.1' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://cwdetroit.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILYoACQ6Ib+naqEuVphNp2e+vQlx22W6W/WzDugy+aCWtUGfKZOAnG6R4J8DqpYVuJQMXZjL+0phZx2QXOCp2PkqZnJySu4tPZS902lmkRVaDXEKTnqwcItXfxF/2iXd+4f2JiLfHFdMGCqhUzA=='></script>
<link rel="https://api.w.org/" href="https://cwdetroit.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://cwdetroit.cbslocal.com/wp-json/wp/v2/posts/59896" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://cwdetroit.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cwdetroit.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.1" />
<link rel='shortlink' href='https://cbsloc.al/33U55Sx' />
<link rel="alternate" type="application/json+oembed" href="https://cwdetroit.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcwdetroit.cbslocal.com%2F2020%2F10%2F13%2Fwest-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://cwdetroit.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fcwdetroit.cbslocal.com%2F2020%2F10%2F13%2Fwest-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others" /><meta property="og:image" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/IMG_1464.jpg?w=1292" /><meta property="og:image:secure_url" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/IMG_1464.jpg?w=1292" /><meta property="og:image:width" content="1292" /><meta property="og:image:height" content="758" /><meta property="og:description" content="A 37-year-old West Bloomfield has been charged with killing a 6-year-old boy and two others, that stemmed over drugs and money according to police. " /><meta property="og:type" content="article" /><meta property="og:url" content="https://cwdetroit.cbslocal.com/2020/10/13/west-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others/" /><meta property="article:published_time" content="2020-10-13T16:49:30+00:00" /><meta property="article:suggested-social-copy" content="A 37-year-old West Bloomfield has been charged with killing a 6-year-old boy and two others, that stemmed over drugs and money according to police. " /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Local,News,Ticker,Uncategorized" /><meta property="article:publisher" content="http://www.facebook.com/cw50detroit" /><meta property="article:author" content="http://www.facebook.com/cw50detroit" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/IMG_1464.jpg?w=1292"><meta name="twitter:title" content="West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others"/><meta name="twitter:description" content="A 37-year-old West Bloomfield has been charged with killing a 6-year-old boy and two others, that stemmed over drugs and money according to police. "/><meta name="twitter:site" content="/cw50detroit"/>
<link rel="canonical" href="https://cwdetroit.cbslocal.com/2020/10/13/west-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://cwdetroit.cbslocal.com/2020/10/13/west-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/cwdetroit.cbslocal.com","url":"https:\/\/cwdetroit.cbslocal.com","name":"CW50 Detroit","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/cwdetroit.cbslocal.com\/wp-content\/uploads\/sites\/31326028\/2018\/07\/4_detroit_cw50.png?w=158"}},"url":"https:\/\/cwdetroit.cbslocal.com\/2020\/10\/13\/west-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/cwdetroit.cbslocal.com\/2020\/10\/13\/west-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others\/"},"headline":"West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others","description":"A 37-year-old West Bloomfield has been charged with killing a 6-year-old boy and two others, that stemmed over drugs and money according to police.\u00a0","image":"https:\/\/cwdetroit.cbslocal.com\/wp-content\/uploads\/sites\/31326028\/2020\/10\/IMG_1464.jpg?w=150&#038;h=150&#038;crop=1","keywords":["Local","News","Ticker","Uncategorized","Bria Brown","Cryss Walker","Execution-Style Killings","Isis Rimson","Nicholas Raad Bahri","Tai'raz Moore","Tukoyo Moore","Warren","Warren Police","news","West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others"],"datePublished":"2020-10-13T16:49:30+00:00","dateModified":"2020-10-13T16:49:30+00:00","author":{"@type":"Organization","name":"CW50 Detroit"},"video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"Microsoft Employees | Working From Home Could Be Permanent For Some","description":"Microsoft is already making plans for the post-pandemic world.\u00a0The technology giant is allowing employees to continue to work from home.\u00a0","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/captures\/13E\/4E2\/13E4E284693C48B48DB8FB8F6D48079D.jpg?Expires=1697241600&KeyName=mcpkey1&Signature=YzNOcZv_WZbinSBAnvCDwd12c6s","uploadDate":"2020-10-13","duration":"T18S","contentUrl":"https:\/\/cwdetroit.cbslocal.com\/video\/4784094-microsoft-employees-working-from-home-could-be-permanent-for-some\/","embedUrl":"https:\/\/cwdetroit.cbslocal.com\/video\/4784094-microsoft-employees-working-from-home-could-be-permanent-for-some\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script>
<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CW.DET","news",["westbloomfieldmanchargedinexecutionstylekillingof6yearoldboy2others","post","article","local","news","ticker","uncategorized","briabrown","crysswalker","executionstylekillings","isisrimson","nicholasraadbahri","tairazmoore","tukoyomoore","warren","warrenpolice","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("2");</script>
<!-- WP Header - End -->

	<meta name="description" content="A 37-year-old West Bloomfield has been charged with killing a 6-year-old boy and two others, that stemmed over drugs and money according to police. " />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-59896 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://cwdetroit.cbslocal.com" id="header-logo"><img src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2018/07/4_detroit_cw50.png?w=158" alt="CW50 Detroit" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Latest Update</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/2020/10/13/west-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others/" title="West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others" class="cbs-thumbnail-link item-1602622170" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/IMG_1464.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others</strong><em class="description">A 37-year-old West Bloomfield has been charged with killing a 6-year-old boy and two others, that stemmed over drugs and money according to police. </em></div></a><a href="https://cwdetroit.cbslocal.com/2020/10/13/michigan-reports-1237-new-covid-19-cases-30-deaths-tuesday/" title="Michigan Reports 1,237 New Covid-19 Cases, 30 Deaths Tuesday" class="cbs-thumbnail-link item-1602616808" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/08/shutterstock_1624635628-2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Michigan Reports 1,237 New Covid-19 Cases, 30 Deaths Tuesday</strong><em class="description">The Michigan Department of Health and Human Services announced 1,237 coronavirus cases in the state and an additional 30 deaths Tuesday.</em></div></a><a href="https://cwdetroit.cbslocal.com/2020/10/12/whitmer-is-confident-michigan-is-prepared-to-conduct-the-november-election-the-right-way/" title="Whitmer Is Confident Michigan Is Prepared To Conduct The November Election The Right Way" class="cbs-thumbnail-link item-1602557937" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/406C111E2A964AAF88DDFA023DBD9266.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Whitmer Is Confident Michigan Is Prepared To Conduct The November Election The Right Way</strong><em class="description">Gov. Gretchen Whitmer appeared on Face the Nation Sunday Where she said she&#039;s confident Michigan is prepared to conduct the November election the right way. </em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Eye on Detroit</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/2020/10/12/making-face-masks-grow-on-trees/" title="Making Face Masks Grow On Trees" class="cbs-thumbnail-link item-1602556226 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/05/TFM3.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Making Face Masks Grow On Trees</strong><em class="description">Karen Sayles makes face masks and hangs them on her tree in her front yard daily.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Coming Up</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/2020/10/10/worlds-apart-swamp-thing/" title="Worlds Apart - Swamp Thing" class="cbs-thumbnail-link item-1602302999" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/SWP-10.13-copy.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Worlds Apart - Swamp Thing</strong><em class="description">Certain that Alec’s disappearance is more than an accident, Abby and Matt venture into the swamp, where she encounters Swamp Thing.</em></div></a><a href="https://cwdetroit.cbslocal.com/2020/10/10/the-curse-tell-me-a-story/" title="The Curse - Tell Me A Story" class="cbs-thumbnail-link item-1602302892" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/TMA-10.13-copy.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">The Curse - Tell Me A Story</strong><em class="description">Rising country music star Ashley Rose Pruitt celebrates the launch of her debut album but a tragic event threatens to derail her success.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://cwdetroit.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
	
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/2020/10/13/west-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others/" title="West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others" class="cbs-thumbnail-link item-1602622170" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/IMG_1464.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others</strong><em class="description">A 37-year-old West Bloomfield has been charged with killing a 6-year-old boy and two others, that stemmed over drugs and money according to police. </em></div></a><a href="https://cwdetroit.cbslocal.com/2020/10/13/michigan-reports-1237-new-covid-19-cases-30-deaths-tuesday/" title="Michigan Reports 1,237 New Covid-19 Cases, 30 Deaths Tuesday" class="cbs-thumbnail-link item-1602616808" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/08/shutterstock_1624635628-2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Michigan Reports 1,237 New Covid-19 Cases, 30 Deaths Tuesday</strong><em class="description">The Michigan Department of Health and Human Services announced 1,237 coronavirus cases in the state and an additional 30 deaths Tuesday.</em></div></a><a href="https://cwdetroit.cbslocal.com/2020/10/12/whitmer-is-confident-michigan-is-prepared-to-conduct-the-november-election-the-right-way/" title="Whitmer Is Confident Michigan Is Prepared To Conduct The November Election The Right Way" class="cbs-thumbnail-link item-1602557937" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/406C111E2A964AAF88DDFA023DBD9266.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Whitmer Is Confident Michigan Is Prepared To Conduct The November Election The Right Way</strong><em class="description">Gov. Gretchen Whitmer appeared on Face the Nation Sunday Where she said she&#039;s confident Michigan is prepared to conduct the November election the right way. </em></div></a><a href="https://cwdetroit.cbslocal.com/2020/10/12/poll-u-s-sen-gary-peters-shows-lead-against-john-james/" title="Poll: U.S. Sen. Gary Peters Shows Lead Against John James" class="cbs-thumbnail-link item-1602557860" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/A1CCE7AEEFD241CD814917E10969120C.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Poll: U.S. Sen. Gary Peters Shows Lead Against John James</strong><em class="description">A new CBS News battleground tracker shows Sen. Gary Peters is currently leading Republican challenger John James by three points.</em></div></a><a href="https://cwdetroit.cbslocal.com/2020/10/12/michigan-medicine-looking-for-volunteers-in-second-covid-19-vaccine-trial/" title="Michigan Medicine Looking For Volunteers In Second Covid-19 Vaccine Trial" class="cbs-thumbnail-link item-1602557794" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/BCF41E064EFC4B71B54B900F3DF93416.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Michigan Medicine Looking For Volunteers In Second Covid-19 Vaccine Trial</strong><em class="description">Michigan Medicine is recruiting at least 60,000 volunteers for its second vaccine trial. Here&#039;s everything you need to know.</em></div></a><a href="https://cwdetroit.cbslocal.com/2020/10/12/eviction-diversion-program-applications-backed-up/" title="Eviction Diversion Program Applications Backed-Up" class="cbs-thumbnail-link item-1602557721" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/IMG_0700.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Eviction Diversion Program Applications Backed-Up</strong><em class="description">A program designed to assist people who fell back on rent is now falling behind on finalizing applications.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link"><a href="http://cwdetroit.cbslocal.com/cw-detroit-tv-schedule" title="TV Schedule" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">TV Schedule</strong></div></a></li><li class="menu-top-item item-3 w-link"><a href="http://cwdetroit.cbslocal.com/tag/cw50-street-team/" title="Street Team" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Street Team</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://cwdetroit.cbslocal.com/category/detroit-proud/" title="Detroit Proud" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Detroit Proud</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
	
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/2020/02/24/detroit-proud-playlist-hamtramck-music-festival/" title="Detroit Proud Playlist: Hamtramck Music Festival" class="cbs-thumbnail-link item-1582565278" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Hamtramck Music Festival</strong><em class="description">The City of Hamtramck comes alive with art, culture, and music via the Hamtramck Music Festival, featuring 200 bands playing 24 venues and restaurants.</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/09/04/detroit-proud-playlist-dally-in-the-alley/" title="Detroit Proud Playlist: Dally In The Alley" class="cbs-thumbnail-link item-1567614651" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Dally In The Alley</strong><em class="description">Dally in the Alley is the go-to event of the summer to discover your new favorite local headliner or underground group. Get into the spirit with this week&#039;s Playlist!</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/07/16/detroit-proud-playlist-pig-whiskey-2019/" title="Detroit Proud Playlist: Pig &amp; Whiskey 2019" class="cbs-thumbnail-link item-1563305958" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Pig &amp; Whiskey 2019</strong><em class="description">Pig &amp; Whiskey Festival encapsulates a Michigan summer in one weekend. We’ve curated a schedule with an eclectic mix of bands that pairs well with any kind of BBQ, brew, or whiskey that you choose to enjoy alongside the music.</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/03/04/detroit-proud-playlist-hamtramck-music-festival-2019/" title="Detroit Proud Playlist: Hamtramck Music Festival 2019!" class="cbs-thumbnail-link item-1551716768" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2019/03/dp-logo_edited-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Hamtramck Music Festival 2019!</strong><em class="description">It&#039;s that time of year again! We’ve selected an eclectic mix of can’t-miss bands playing this weekend&#039;s Hamtramck Music Festival for this week&#039;s Detroit Proud Playlist!</em></div></a><a href="https://cwdetroit.cbslocal.com/2019/02/18/detroit-proud-playlist-guest-dj-vazum-frontman-zach-pliska/" title="Detroit Proud Playlist: Guest DJ - VAZUM Frontman Zach Pliska!" class="cbs-thumbnail-link item-1550466084" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2013/08/dpplaylistimage2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Guest DJ - VAZUM Frontman Zach Pliska!</strong><em class="description">This week, we have a special Guest DJ-ed playlist, curated by VAZUM frontman Zach Pliska! Zach put his own spin on our Detroit Proud Playlist this week - check out his picks below!</em></div></a><a href="https://cwdetroit.cbslocal.com/2018/12/03/detroit-proud-playlist-week-of-12-3/" title="Detroit Proud Playlist: Week of 12/3" class="cbs-thumbnail-link item-1543848574" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2013/07/dpplaylistimage2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Detroit Proud Playlist: Week of 12/3</strong><em class="description">The playlist is here for another week of Detroit music! We have new tunes, old tunes, and a little something for everyone. Check it out!</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://cwdetroit.cbslocal.com/video/category/spoken-word-wkbdtv/">News</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/video/4785705-mysterious-islands-host-kellee-edwards-the-first-black-woman-to-host-a-show-for-the-travel-channel/" title="&#039;Mysterious Islands&#039; Host Kellee Edwards, The First Black Woman To Host A Show For The Travel Channel" class="cbs-thumbnail-link item-1602608400 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-pvw/DDE/B68/DDEB68BE0CA148F9B0FCEFC07723634C_4.jpg?Expires=1697241600&#038;KeyName=mcpkey1&#038;Signature=GHnlvyMr2zb8Jl1couyM88tD2oY"></span></div><div class="title-wrapper"><strong class="title">&#039;Mysterious Islands&#039; Host Kellee Edwards, The First Black Woman To Host A Show For The Travel Channel</strong><em class="description">#ShareTheMicwithLuvvie Spotlights “Mysterious Islands” Host Kellee Edwards, The First Black Woman To Host A Show For The Travel Channel</em></div><time datetime="2020-10-13T17:00:00+00:00" title="October 13, 2020 at 1:00 pm">9 hours ago</time></a><a href="https://cwdetroit.cbslocal.com/video/4785701-gloria-reveals-she-went-on-her-sons-first-date-the-ladies-discuss-spying-on-your-partner/" title="Gloria Reveals She Went On Her Son’s First Date &amp; The Ladies Discuss Spying On Your Partner" class="cbs-thumbnail-link item-1602606600 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-pvw/1E8/444/1E844427A5BF44598536D1F251924A6D_6.jpg?Expires=1697241600&#038;KeyName=mcpkey1&#038;Signature=XE90C50UmkKI8_K3rNth8lybFRE"></span></div><div class="title-wrapper"><strong class="title">Gloria Reveals She Went On Her Son’s First Date &amp; The Ladies Discuss Spying On Your Partner</strong><em class="description">Gloria Reveals She Went On Her Son’s First Date &amp; The Ladies Discuss Spying On Your Partner</em></div><time datetime="2020-10-13T16:30:00+00:00" title="October 13, 2020 at 12:30 pm">9 hours ago</time></a><a href="https://cwdetroit.cbslocal.com/video/4785684-gloria-estefan-drew-on-40s-being-the-best-years-of-their-lives/" title="Gloria Estefan &amp; Drew on 40’s Being The Best Years of Their Lives" class="cbs-thumbnail-link item-1602604260 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-pvw/F49/FE7/F49FE7928024471883CA34D585EF6F05_3.jpg?Expires=1697241600&#038;KeyName=mcpkey1&#038;Signature=Bwss8F3HtMWFoKK7_-E_M2S1Jls"></span></div><div class="title-wrapper"><strong class="title">Gloria Estefan &amp; Drew on 40’s Being The Best Years of Their Lives</strong><em class="description">Music legend Gloria Estefan, her daughter Emily Estefean &amp; Niece Lili Estefan on their new show ‘Red Table Talk: The Estefans’</em></div><time datetime="2020-10-13T15:51:00+00:00" title="October 13, 2020 at 11:51 am">10 hours ago</time></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-3 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Community Affairs</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://cwdetroit.cbslocal.com/video/4776610-community-connect-breast-cancer-and-liver-cancer-awareness/" title="Community Connect: Breast Cancer and Liver Cancer Awareness" class="cbs-thumbnail-link item-1602329400 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/BF6/0B1/BF60B132F8F24B3E94E25E020251DE6E.jpg?Expires=1697241600&#038;KeyName=mcpkey1&#038;Signature=KAlBY7Lgm_dIQ2TkYuEuIdg-Yds"></span></div><div class="title-wrapper"><strong class="title">Community Connect: Breast Cancer and Liver Cancer Awareness</strong><em class="description">On this week’s Community Connect, we hear personal stories from those touched by Breast Cancer and Liver Cancer.</em></div><time datetime="2020-10-10T11:30:00+00:00" title="October 10, 2020 at 7:30 am">4 days ago</time></a><a href="https://cwdetroit.cbslocal.com/video/4777603-imerman-angels-forms-one-on-one-connections-with-survivors-pairs-them-with-others-fighting-same-type-of-cancer/" title="Imerman Angels Forms One-On-One Connections With Survivors, Pairs Them With Others Fighting Same Type Of Cancer" class="cbs-thumbnail-link item-1602243000 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/DBA/2A6/DBA2A6E823E74926BC78A5B8588D56D4.jpg?Expires=1697241600&#038;KeyName=mcpkey1&#038;Signature=MHieb0qjnaQSh7Pkaimd5SSu10o"></span></div><div class="title-wrapper"><strong class="title">Imerman Angels Forms One-On-One Connections With Survivors, Pairs Them With Others Fighting Same Type Of Cancer</strong><em class="description">Jonny Imerman, Founder of Imerman Angels, joins Lisa Germani on Community Connect to share his story of fighting cancer at 26 years old, and how that led to him founding Imerman Angels.</em></div><time datetime="2020-10-09T11:30:00+00:00" title="October 9, 2020 at 7:30 am">5 days ago</time></a><a href="https://cwdetroit.cbslocal.com/video/4759198-friends-for-animals-of-metro-detroit-helps-make-life-changing-connections-between-people-animals-they-adopt/" title="Friends For Animals Of Metro Detroit Helps Make Life-Changing Connections Between People, Animals They Adopt" class="cbs-thumbnail-link item-1601724600 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/77E/2D9/77E2D9408E5D46588948FE1A484993AA.jpg?Expires=1697241600&#038;KeyName=mcpkey1&#038;Signature=hfH1BZ4H9rqwuSojvWXOqtjK3y0"></span></div><div class="title-wrapper"><strong class="title">Friends For Animals Of Metro Detroit Helps Make Life-Changing Connections Between People, Animals They Adopt</strong><em class="description">Sarah Rood, Marketing and Communications Manager of Friends for Animals of Metro Detroit, and adoptable dog Howly Mandel, join Lisa Germani on Community to help find Howly Mandel a forever home.</em></div><time datetime="2020-10-03T11:30:00+00:00" title="October 3, 2020 at 7:30 am">11 days ago</time></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-link"><a href="http://detroit.cbslocal.com/" title="CBS Detroit" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CBS Detroit</strong></div></a></li></ul></nav>
	<ul id="live"><li class="menu-item item-0"><a href="/live/channel/wwj-tv/" title="WWJ-TV" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">WWJ-TV</strong><em class="description">On Air</em></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">7:00 PM</strong><em class="description">NFL Football</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">10:00 PM</strong><em class="description">The FBI Declassified</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">11:00 PM</strong><em class="description">Two and a Half Men</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">11:35 PM</strong><em class="description">The Late Show with Stephen Colbert</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">12:37 AM</strong><em class="description">The Late Late Show with James Corden</em></div></div></div>
</div></div><a class="view-all" href="https://cwdetroit.cbslocal.com/program-guide/">View All Programs</a></div></div></li></ul>
	
	<div id="info-search"><form action="https://cwdetroit.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">October 13, 2020 at 4:49 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://cwdetroit.cbslocal.com/tag/bria-brown/">Bria Brown</a>, <a href="https://cwdetroit.cbslocal.com/tag/cryss-walker/">Cryss Walker</a>, <a href="https://cwdetroit.cbslocal.com/tag/execution-style-killings/">Execution-Style Killings</a>, <a href="https://cwdetroit.cbslocal.com/tag/isis-rimson/">Isis Rimson</a>, <a href="https://cwdetroit.cbslocal.com/tag/nicholas-raad-bahri/">Nicholas Raad Bahri</a>, <a href="https://cwdetroit.cbslocal.com/tag/tairaz-moore/">Tai&#039;raz Moore</a>, <a href="https://cwdetroit.cbslocal.com/tag/tukoyo-moore/">Tukoyo Moore</a>, <a href="https://cwdetroit.cbslocal.com/tag/warren/">Warren</a>, <a href="https://cwdetroit.cbslocal.com/tag/warren-police/">Warren Police</a></div></div></section><section id="column_block_2" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato-program  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id="p0"></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"4784094","autoplay":true,"titleVisible":false,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5"},"comscore":{"clientId":"3000023","c3":"cwdetroit.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/cw.det&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/cbsloc.al\/33U55Sx","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5,"recom":true,"maxRecomPages":3});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>(CBS DETROIT)</strong> &#8211; A 37-year-old West Bloomfield has been charged with killing a 6-year-old boy and two others, that stemmed over drugs and money according to police.</p>
<p>Nicholas Raad Bahri, is believed to be responsible for the deaths of 6-year-old Tai&#8217;Raz Moore and Isis Rimson who were found in the basement of a home on Otis Street in Warren Oct. 1.</p>
<p><img loading="lazy" class="aligncenter size-full wp-image-1045878" src="https://detroit.cbslocal.com/wp-content/uploads/sites/15909782/2020/10/IMG_1459.jpg" alt="" width="420" height="520"></p>
<p>Rimson was engaged to Moore&#8217;s father, 31-year-old Tukoyo Moore, whose body was found inside of a car after being set on fire. Warren Police Commissioner William Dwyer said Bahri is believed to be responsible for Moore&#8217;s father&#8217;s death as well.</p>
<p>Last week, police raided a home in West Bloomfield and a man was taken into custody in connection to the murders of 6-year-old Tai&#8217;raz Moore and Isis Rimson who were found in the basement of a home on Otis Street in Warren Oct. 1.</p>
<p><a href="https://detroit.cbslocal.com/2020/10/02/warren-police-want-fbi-involved-in-execution-style-murders-of-woman-6-year-old-boy/"><strong>RELATED LINK: Warren Police Want FBI Involved In Execution-Style Murders Of Woman, 6-Year-Old Boy</strong></a></p>
<p>Bahri is charged with 15 counts which included three charges of premeditated homicide and related weapons offenses, arson, and disinterment and mutilation of a dead body. He was denied bond.</p>
<p><em>&copy; 2020 CBS Broadcasting Inc. All Rights Reserved. This material may not be published, broadcast, rewritten, or redistributed.</em></p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/33U55Sx"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/33U55Sx"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/33U55Sx"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected"><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-3"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://www.facebook.com/cw50detroit" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/cw50detroit" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://cwdetroit.cbslocal.com/2020/10/09/man-pleas-for-kidney-on-facebook-receives-one-from-complete-stranger/" title="Man Pleas For Kidney On Facebook, Receives One From Complete Stranger" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/Screen-Shot-2020-10-09-at-2.08.36-PM-e1602267153841.png?resize=55%2C55&#038;ssl=1" alt="Man Pleas For Kidney On Facebook, Receives One From Complete Stranger" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/10/09/man-pleas-for-kidney-on-facebook-receives-one-from-complete-stranger/" title="Man Pleas For Kidney On Facebook, Receives One From Complete Stranger" class="bump-view" data-bump-view="tp">Man Pleas For Kidney On Facebook, Receives One From Complete Stranger</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2020/10/10/say-hello-to-my-little-ball-pit-troll-penn-teller-fool-us/" title="Say Hello to My Little Ball Pit Troll - Penn &amp; Teller: Fool Us" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/PEN-10.12-copy.jpg?resize=55%2C55&#038;ssl=1" alt="Say Hello to My Little Ball Pit Troll - Penn &amp; Teller: Fool Us" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/10/10/say-hello-to-my-little-ball-pit-troll-penn-teller-fool-us/" title="Say Hello to My Little Ball Pit Troll - Penn &amp; Teller: Fool Us" class="bump-view" data-bump-view="tp">Say Hello to My Little Ball Pit Troll - Penn &amp; Teller: Fool Us</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2020/10/13/west-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others/" title="West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others" class="bump-view" data-bump-view="tp" aria-current="page">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/IMG_1464.jpg?resize=55%2C55&#038;ssl=1" alt="West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/10/13/west-bloomfield-man-charged-in-execution-style-killing-of-6-year-old-boy-2-others/" title="West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others" class="bump-view" data-bump-view="tp" aria-current="page">West Bloomfield Man Charged In Execution-Style Killing Of 6-Year-Old Boy, 2 Others</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2020/09/30/dennis-williams-ex-uaw-president-pleads-guilty-in-embezzlement-scheme/" title="Dennis Williams, Ex-UAW President Pleads Guilty In Embezzlement Scheme" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/09/dennis-williams-e1601501873588.jpg?resize=55%2C55&#038;ssl=1" alt="Dennis Williams, Ex-UAW President Pleads Guilty In Embezzlement Scheme" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/09/30/dennis-williams-ex-uaw-president-pleads-guilty-in-embezzlement-scheme/" title="Dennis Williams, Ex-UAW President Pleads Guilty In Embezzlement Scheme" class="bump-view" data-bump-view="tp">Dennis Williams, Ex-UAW President Pleads Guilty In Embezzlement Scheme</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2020/10/12/gov-whitmer-signs-clean-slate-bills-expanding-michigans-expungement-laws/" title="Gov. Whitmer Signs &#039;Clean Slate&#039; Bills Expanding Michigan&#039;s Expungement Laws" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/presser1-052820_original-1.jpg?resize=55%2C55&#038;ssl=1" alt="Gov. Whitmer Signs &#039;Clean Slate&#039; Bills Expanding Michigan&#039;s Expungement Laws" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/10/12/gov-whitmer-signs-clean-slate-bills-expanding-michigans-expungement-laws/" title="Gov. Whitmer Signs &#039;Clean Slate&#039; Bills Expanding Michigan&#039;s Expungement Laws" class="bump-view" data-bump-view="tp">Gov. Whitmer Signs &#039;Clean Slate&#039; Bills Expanding Michigan&#039;s Expungement Laws</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2020/10/13/michigan-reports-1237-new-covid-19-cases-30-deaths-tuesday/" title="Michigan Reports 1,237 New Covid-19 Cases, 30 Deaths Tuesday" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/08/shutterstock_1624635628-2.jpg?resize=55%2C55&#038;ssl=1" alt="Michigan Reports 1,237 New Covid-19 Cases, 30 Deaths Tuesday" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/10/13/michigan-reports-1237-new-covid-19-cases-30-deaths-tuesday/" title="Michigan Reports 1,237 New Covid-19 Cases, 30 Deaths Tuesday" class="bump-view" data-bump-view="tp">Michigan Reports 1,237 New Covid-19 Cases, 30 Deaths Tuesday</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2020/10/12/gov-whitmer-signs-historic-bipartisan-clean-slate-bills-expanding-expungement-opportunities/" title="Gov. Whitmer Signs Historic Bipartisan &#039;Clean Slate&#039; Bills Expanding Expungement Opportunities" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/expungement-signing_original.jpg?resize=55%2C55&#038;ssl=1" alt="Gov. Whitmer Signs Historic Bipartisan &#039;Clean Slate&#039; Bills Expanding Expungement Opportunities" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/10/12/gov-whitmer-signs-historic-bipartisan-clean-slate-bills-expanding-expungement-opportunities/" title="Gov. Whitmer Signs Historic Bipartisan &#039;Clean Slate&#039; Bills Expanding Expungement Opportunities" class="bump-view" data-bump-view="tp">Gov. Whitmer Signs Historic Bipartisan &#039;Clean Slate&#039; Bills Expanding Expungement Opportunities</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2020/10/10/amber-riley-whose-line-is-it-anyway-4/" title="Amber Riley - Whose Line Is It Anyway?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/03/Whose-Line-3.30.jpg?resize=55%2C55&#038;ssl=1" alt="Amber Riley - Whose Line Is It Anyway?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/10/10/amber-riley-whose-line-is-it-anyway-4/" title="Amber Riley - Whose Line Is It Anyway?" class="bump-view" data-bump-view="tp">Amber Riley - Whose Line Is It Anyway?</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2020/05/19/luke-wilson-dc-stargirl-brec-bassinger-the-cw/" title="Luke Wilson And Brec Bassinger On &#039;DC&#039;s Stargirl&#039;: &#039;If It Can Make One Person Smile That&#039;s Going Through A Hard Time, That&#039;s Good Enough For Me&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/05/STARGIRL.jpg?resize=55%2C55&#038;ssl=1" alt="Luke Wilson And Brec Bassinger On &#039;DC&#039;s Stargirl&#039;: &#039;If It Can Make One Person Smile That&#039;s Going Through A Hard Time, That&#039;s Good Enough For Me&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/05/19/luke-wilson-dc-stargirl-brec-bassinger-the-cw/" title="Luke Wilson And Brec Bassinger On &#039;DC&#039;s Stargirl&#039;: &#039;If It Can Make One Person Smile That&#039;s Going Through A Hard Time, That&#039;s Good Enough For Me&#039;" class="bump-view" data-bump-view="tp">Luke Wilson And Brec Bassinger On &#039;DC&#039;s Stargirl&#039;: &#039;If It Can Make One Person Smile That&#039;s Going Through A Hard Time, That&#039;s Good Enough For Me&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://cwdetroit.cbslocal.com/2020/10/10/jeff-davis-11-whose-line-is-it-anyway/" title="Jeff Davis 11 - Whose Line Is It Anyway?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2020/10/WL-10.12-copy.jpg?resize=55%2C55&#038;ssl=1" alt="Jeff Davis 11 - Whose Line Is It Anyway?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://cwdetroit.cbslocal.com/2020/10/10/jeff-davis-11-whose-line-is-it-anyway/" title="Jeff Davis 11 - Whose Line Is It Anyway?" class="bump-view" data-bump-view="tp">Jeff Davis 11 - Whose Line Is It Anyway?</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://cwdetroit.cbslocal.com" class="logo"><img src="https://cwdetroit.cbslocal.com/wp-content/uploads/sites/31326028/2015/09/cw50_230x86.png" alt="CW50 Detroit" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/cw50detroit" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/cw50detroit" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
	
			<section class="bottom"><div class="wrapper">
			<a href="https://cwdetroit.cbslocal.com" class="logo"><img src="https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CW50 Detroit" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2020 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=cwdetroit.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-263" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-263"><a href="http://policies.cbslocal.com/privacy/current.html">Privacy Policy</a></li>
<li id="menu-item-262" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-262"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-52918" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52918"><a href="https://ca.privacy.cbs/">California Privacy/Info We Collect</a></li>
<li id="menu-item-52919" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-52919"><a href="https://ca.privacy.cbs/donotsell">California Do Not Sell My Info</a></li>
<li id="menu-item-36241" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36241"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-36242" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-36242"><a href="https://privacy.cbs/personalizedads">Ad Choices</a></li>
<li id="menu-item-264" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-264"><a href="http://cwdetroit.cbslocal.com/contact-us/">Contact Us</a></li>
<li id="menu-item-10825" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10825"><a href="http://cbsdetroit.com/eeo">EEO Report</a></li>
<li id="menu-item-16485" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16485"><a href="http://publicfiles.fcc.gov/tv-profile/wkbd-tv">Public File for WKBD-TV / CW50 Detroit</a></li>
<li id="menu-item-49756" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49756"><a href="http://policies.cbslocal.com/fcc/detroit.television.contact.html">Public File Contact Us for WKBD-TV / CW50 Detroit</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='screen-css-0' href='https://cwdetroit.cbslocal.com/_static/??-eJzTLy/QTc7PK0nNK9EvyUjNTS3WT04q1s3JT07M0c/MS84pTQEKpeYmpaYAZYqhTN2czOISPSBXR598/UB9uQWJyWBz7HNtDU0tDQ0NTSyMDQEaHzWi' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://cwdetroit.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1591114831g' type='text/css' media='all' />
<script type='text/javascript' src='https://cwdetroit.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1598987409g'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.5.1' id='cbs-cbs-anvato-js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202042.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'162246157',post:'59896',tz:'-4',srv:'cwdetroit.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246157', '59896' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"103fa8ca15","applicationID":"144794115","transactionName":"ZwdaZBdUX0VTVEBRC15NeVMRXF5YHV5aXAFI","queueTime":0,"applicationTime":256,"atts":"S0BNEl9OTBoQVhYCH00f","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>